Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Changnoi1
New

Currency for renewal payment

My default currency = USD, my payment methode is in EURO but when I want to pay the renewal of my domain the price is in the currency where I am at the moment!!!! And looking to the price there is being used now twice a exchange rate, and twice not a very good exchange rate! Did someone at the management thought this is a smart way of making money and nobody would notice? There are a lot of complains about it but I see nowhere a solution for it.

 

So how can I change the payment currency? Because if not then this would be a good moment to transfer my domains to a provider where I can pay in any currency I want.

 

 

1 ACCEPTED SOLUTION
JesseW
Community Manager

Hi @Changnoi1. Sorry you're having trouble. There are three ways to change your payment currency. First, you can change it in your profile under account settings. Changing it here should update the default currency you use. Second, you can change it on each payment method individually by editing it. Third, you can change it at the bottom of the page, even while you're in the shopping cart. 

 

change currency.png

 

If for some reason these changes don't take effect, I'd suggest first clearing your browser's cache and cookies. If that doesn't help, then try using a cacheless browsing window (FireFox private window, Chrome incognito, etc.), then an entirely different browser. If that also doesn't work, please connect with our customer care team

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give likes.

View solution in original post

1 REPLY 1
JesseW
Community Manager

Hi @Changnoi1. Sorry you're having trouble. There are three ways to change your payment currency. First, you can change it in your profile under account settings. Changing it here should update the default currency you use. Second, you can change it on each payment method individually by editing it. Third, you can change it at the bottom of the page, even while you're in the shopping cart. 

 

change currency.png

 

If for some reason these changes don't take effect, I'd suggest first clearing your browser's cache and cookies. If that doesn't help, then try using a cacheless browsing window (FireFox private window, Chrome incognito, etc.), then an entirely different browser. If that also doesn't work, please connect with our customer care team

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give likes.

View solution in original post