• GoDaddy Community
  • GoCentral | Website Builder
  • GoCentral | Website Builder

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 
    Go to solution

    Website not appearing correctly on internet explorer but is correct on Chrome

    Hi there, I have noticed that my website www.gorgemagazines.co.nz isn't appearing correctly on internet explorer. It appears correct on chrome. It was built in the website builder through go central. Please can someone help me fix this? 

    3 REPLIES 3
    Super User I Super User I
    Super User I
    Solution

    Re: Website not appearing correctly on internet explorer but is correct on Chrome

    When you say Internet Explorer do you actually mean Edge @B-NewZealand? If you are actually using Internet Explorer I assume you are using version 11? I must say, as a designer I no longer check or code to IE by default. I couldn't tell you for sure that IE was up to the task of displaying a modern website? 

     

    I would suggest that you download Microsoft Edge and moving forward that you not use Internet Explorer. I hope that helps? 

     

    ...turns out that my two cents is worth less or more depending on the current exchange rate.

    roy darling *my posts seem a lot shorter in my head

    Re: Website not appearing correctly on internet explorer but is correct on Chrome

    Thanks for your reply. I don't use internet explorer myself but I was curious to see what my website looked like on it. Hopefully no one uses that these days as my site clearly looks not that appealing on it haha. Thanks for your help @rd. 👍

    Helper V

    Re: Website not appearing correctly on internet explorer but is correct on Chrome

    Microsoft themselves came out in February 2019 and said no one should be using IE anymore. Folks should be moving off it if they haven't done so already.