Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
ono777
New

Email about Migration old Web Hosting to Linux Hosting with cPanel

I received an email that my web hosting will migrate this week to new Web Hosting Linux with cPanel.

I've a site (web service) that needs to run with PHP 5.2, and I want to be sure that new web hosting will still support PHP 5.2.. 

Do you have any info about it?

 

 

1 ACCEPTED SOLUTION

@ono777 

 

I just looked on a cPanel I have access to and it was 5.6, 7.3, 7.4 and 8.0

It's been a while since I did anything with Zend - but I thought that if the encoded matched to the PHP version - it would still work - in other words as long as you updated both PHP and Zend it should be good

 

There is something called Hardened PHP which allows you to run older versions (with security features) - I'm not sure if this is only on specific providers or on any VPS (you'd need to know command line setup if you are on a VPS)

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

3 REPLIES 3
PL281
Super User IV

@ono777 

 

I'm pretty sure the oldest version that cPanel will support is 5.4

 

There are some ways to run older versions of PHP but it is my understanding you need a host / server that specifically supports this - I think you maybe able to it with a VPS server but not 100% on that

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Thanks for your reply.

My website needs PHP 5.2 because its script is encoded with Zend, and I need Zend Optimizer (that can't run on PHP versions> 5.2)

In chat support the operator says me that cPanel will support also PHP 5.2, but I don't trust ..
Do you know of any hosting / VPS that can run PHP 5.2 with Zend Optimizer module?

 

@ono777 

 

I just looked on a cPanel I have access to and it was 5.6, 7.3, 7.4 and 8.0

It's been a while since I did anything with Zend - but I thought that if the encoded matched to the PHP version - it would still work - in other words as long as you updated both PHP and Zend it should be good

 

There is something called Hardened PHP which allows you to run older versions (with security features) - I'm not sure if this is only on specific providers or on any VPS (you'd need to know command line setup if you are on a VPS)

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post