Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Getting Started

FTP connected but unable to transfer files

I have been using CoreFTP to upload files to my site. But since GoDaddy informed me last week that my hosting account had been "updated" (whatever that meant -- definitely nothing I requested), FTP no longer works properly. CoreFTP connects, but never displays the directory from the server.


So I've tried using FTP directly from the command line. It accepts my username and password and seems to connect successfully, with a message


230 OK. Current restricted directory is /


ls command then seems to be accepted with a "200 port command successful", but after a long wait fails with the message


425 Could not open data connection to port 54721: Connection timed out


I've tried turning off my firewall. Doesn't help.


Any ideas how to fix this. It appears to be a problem on the GoDaddy end, but I see nothing I can control in the File Manager that might help (like making sure directories are accessible). I can still upload files one-by-on in the File Manger, but this is not feasible when I do larger website updates that touch many files.


I'm having the exact same problem since the "updated" my hosting.  FTP will connect but not list files.  When I look at the log it appears to be trying to change to a different IP address when I list files.

Hmm. I don't get the impression that it is trying another IP address, but it definitely is using a different port for the ls command, and a different one for file transfers. I am supposing that port is somehow being blocked, but it does not appear to be my firewall, though it might be one somewere down the line.


The interesting thing I just discovered is that although no computer trying to connect directly through my home internet connection (Comcast) succeeds with FTP, my work laptop does connect if I start up VPN on it (but not without VPN). So evidently VPN is able to evade whatever firewall-type filtering is happening.


I'm looking into whether I can get a VPN account for my private use. But maybe something else would help, given this hint. Like SFTP, maybe? Is there a way to use it in my hosting account?


Any other ideas?

You're right it was just ports, not an IP address.  I switched my FTP mode to passive and it now works.  Not sure if there are negative implications to that, but I'm FTPing fine now.

Hmm. For me, just going to passive mode was not enough. I was successful only by both connecting via VPN rather than directly, plus using passive mode in FTP. Neither alone worked.

Worked for me also. Thanks.

This drove me crazy forever - I needed to ftp to godaddy from a raspberry pi (so I couldn't use filezilla) and it was hanging.  Switching to passive mode as was suggested above worked...thank you!