Showing results for 
Show  only  | Search instead for 
Did you mean: 

FTP upload via Linux or Dos commandline hangs

Sometime within last 30-45 days my local scripts that ftp images to my hosted account have stopped working.   I use commandline scripts from a Linux box, and also tried via dos ftp.

Hosted site allows me to login and send ftp commands but the upload and ls commands fail to return a result. 

I tried uploading a small test.jpg file and get a response "230 User logged in", then when I command bin it responds with "200 PORT command successful" but when I try and "put" the test.jpg file it responds with "150 Opening BINARY mode data connection" and I get no more response, and have to ctrl-c to get out and end up disconnected.

I have tried from different machines on different internet accounts with the same results.

I have used this process for many years, have confirmed nothing changed with permissions.

Any thoughts?


Community Manager

Hi @Yobud. Thanks for being part of GoDaddy Community! This sounds like it could be a firewall issue to me. You may want to check that on your end. If you're not seeing any issues with your firewall, then I'd recommend getting in touch with our hosting support team so they can take a closer look. Hope you're able to get it figured out. 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.