cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution

How to request a PHP 5.4.0 (or greater) upgrade?

Let me say upfront I do not know anything about PHP. I am being shown an error message by Wordpress when I try to install a plug in which says "Error. You need PHP 5.4.0 (or greater). Current php version: 5.2.17"  How do I request GoDaddy upgrade my account to PHP 5.4.0(or greater)?  Is this a big deal? Will it cause problems with the rest of my website? 

1 REPLY 1
Employee
Employee
Solution

Re: How to request a PHP 5.4.0 (or greater) upgrade?

The only time this will cause a problem is if another plugin or theme is *way* out of date. Like not updated in the last 5 years.

The upgrade is usually simple, here are the instructions: https://www.godaddy.com/help/view-or-change-your-php-version-3937

If you don't see other php versions, you may need to upgrade from classic to web hosting. This can get complicated if you're in one of GoDaddy's older datacenters, I'd call hosting support before doing this.

If you're set to a newer version but your site is still running on php 5.2, you've got a setting in either your .htaccess or php5.ini causing it.