Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No permission to stored procedures after Godaddy unexplained 'outage' two weeks ago

I've been desperately trying to access the 'stored procedures' within my database, two weeks ago there was an unexplained outage on my shared server for 3+ hours, after which I did not have permission to access the stored procedures within my database.  I've had numerous conversations with Godaddy support - pleading with them to send me an SQL export of my stored procedures so I can drop and recreate them (they are not included in backups as my 'root' cPanel account now doesn't have access) when I try to access them in PhpMyAdmin I get the error:  " Error in processing request: No routine with name `ProcedureName` found in database `DATABASENAME. You might be lacking the necessary privileges to edit this routine."  Although the procedure IS there, and does still function.   I get suggestions from support like:

"Well, I have tried from my end and I am not getting any error...would suggest you to once try from different browsers or private window..also Please try with different Internet Service Provider If possible.." 

Which obviously we have tried many different ways from Sunday to access our PhpMyAdmin already to see if the access permission where different (i.e. other browsers, other computers with other browsers, other Internet connections)...

Totally unhappy with the response I've received with this issue, the inept service from Godaddy has led me to look for another web hosting provider - there are two solutions 1) reset the permissions, 2) send me an export.   After three long conversations with support I am still unable to have them arrive at those actions.... here's an example of their inept service:

Connecting you with one of our GoDaddy Guides. You can message us at your own pace and we will respond within 5 minutes.

 at 0:47, Nov 1:
I have an existing issue that I've phoned about and email support many times about - to date I have not received a satisfactory resolution. Since 'the outage' which affected our account two weeks ago we have not been able to edit, backup or access any of the stored procedures in our database "DATABASENAME", the recommended solution was to backup the database and then recreate the stored procedures from the backups, but the backups don't contain the stored procedures because for whatever reason (due to what happened that day) we no longer 'have permission' to do so. Our procedures are still listed, still work, but we have no means to edit or back them upRead
<<CHAT Data Removed for security>>

at 0:55, Nov 1:
" Error in processing request: No routine with name `STOREDPROCEDURENAME` found in database `DATABASENAME`. You might be lacking the necessary privileges to edit this routine." when we click on a listed stored procedure in our databaseRead
<<CHAT Data Removed for security>>