cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New

Web Services going into "sleep mode"

I'm hosting WCF web services using GoDaddy, and these services get used from a web app as well as a mobile app.  I've noticed that after a period of inactivity (maybe 15 minutes), these services are very slow to respond to the first request.  After that, they are quick.  This initial delay has caused a problem due to the way the apps need to communicate with the database.

 

In Azure, they have a setting called "Always on" which prevents that initial response from being slow.

 

Is there a similar setting in GoDaddy web hosting?

 

Thanks...

1 REPLY 1
Highlighted

Re: Web Services going into "sleep mode"

Did you ever find a solution to this issue? I'm hitting the same wall at the moment. I developed a RESTful data service and deployed it to AWS as an experiment but then moved it into a virtual directory next to my GoDaddy hosted site. When I was in development the AWS Elastic Beanstalk response time was never more than 3-5 seconds. However on GoDaddy I encountered the same issue as yours. After 15 to 20 minutes it falls asleep and the first visitor has to wait over 50 seconds before the return.