Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wordpress 500 error .htaccess issue

I have recently uploaded a locally built Wordpress site to standard hosting with GoDaddy.

Following upload of everything, the site will only display the 500 http error message.

Support told me .htaccess was causing the issue. I have tried removing .htaccess, renaming, and still no joy. Plugins off/on through file manager, same issue.

Please help!
Super User 2020

Hey there @islands501,


Thanks for being a part of the community!


Since you've deleted/renamed your .htaccess and turning off the plugins didn't work, I would think it's either (a) your theme or (b) some sort of core file corruption of the WordPress installation itself. Have you turned on debugging to see if it gives you any sort of detailed error statement? If not, you can do so by following these instructions.


Also, what is the domain? I'll take a look and see if I notice anything.

I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

So having turned on the debug log, upon visiting the site (, all that was then visible was:

Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /home/o2dudohqiy39/public_html/wp-includes/compat.php on line 502

Fatal error: Uncaught Error: Class 'WP_Widget_Archives' not found in /home/o2dudohqiy39/public_html/wp-includes/class-wp-widget-factory.php:106 Stack trace: #0 /home/o2dudohqiy39/public_html/wp-includes/widgets.php(113): WP_Widget_Factory->register('WP_Widget_Archi...') #1 /home/o2dudohqiy39/public_html/wp-includes/widgets.php(1446): register_widget('WP_Widget_Archi...') #2 /home/o2dudohqiy39/public_html/wp-includes/plugin.php(524): wp_widgets_init('') #3 /home/o2dudohqiy39/public_html/wp-settings.php(411): do_action('init') #4 /home/o2dudohqiy39/public_html/wp-config.php(92): require_once('/home/o2dudohqi...') #5 /home/o2dudohqiy39/public_html/wp-load.php(39): require_once('/home/o2dudohqi...') #6 /home/o2dudohqiy39/public_html/wp-blog-header.php(13): require_once('/home/o2dudohqi...') #7 /home/o2dudohqiy39/public_html/index.php(17): require('/home/o2dudohqi...') #8 {main} thrown in /home/o2dudohqiy39/public_html/wp-includes/class-wp-widget-factory.php on line 106