Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, August 4th at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • GoDaddy Website Builders
  • GoDaddy Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    cherry
    New

    Unable to add email marketing to GoCentral website

    Hi

     

    I've created my website and added each section. read the tutorials and followed the steps.

     

    Then I added a Subscribe section. the details of the Subscription section doesn't show up on my website.  That section shows nothing, as if I didn't click on adding a section.

     

    I still filled out all the text boxes, and then at the bottom of the page there was a green button for "Email Marketing". I clicked on it and then was redirected to Publish a signup form and advanced sign up. Filled out everything and then the instructions were to click on the Embed button to get the HTML code. the instructions say:

     

    "7. Paste the code into your site editor, wherever you want your sign-up form to be published."

     

    however, I can't find an HTML editor in GoCentral. 

     

     

    On the 'Signup forms' page I tried to turn on and off the "Set as default" button. Made no difference.

     

    Now when I return to edit my website, I click again to add a Subscribe section, it again doesn't show up on the website. in addition, now I am unable edit the Subscribe section. The entire section is  also blank - no more text boxes available for me to edit, anymore. 

     

    Whatever I choose, no email signup appears anywhere on my website. 

     

    Your assistance would be most appreciated,

     

    Thanks

     

     

     

    4 REPLIES 4
    Muse
    Super User II

    @cherry

     

    I have a test account for GoCentral and discovered the same thing! So I checked it out and received confirmation that there is no way to embed the email marketing code -- or any HTML -- into the GoCentral interface.  Not now anyway.

     

    Apparently this is something they are looking at for future releases -- no ETA yet.

     

    For now you just have access to the Subscribe widget that asks for the email address only.

     

    HTH! 😉

    Judith
    "Good things happen to those who hustle." ~ Anaïs Nin

    Thanks for replying. Much appreciated.

     

    On the 'Signup forms' page I tried to turn off the "Set as default" button. 

     

    Then returned to Edit in GoCentral. I created a new  Subscribe section. The text boxes appear and everything. however it isn't visible on my website. It isn't in the footer or anywhere else on the page. Even in Preview. There is no button for anyone to Subscribe.

     

     

    Do you know how to add the Subscribe widget to the website?

     

    Thanks in advance.

    Muse
    Super User II

    @cherry

     

    Hmmm.... not sure what is up based on your description.  Did you complete the Subscribe widget setup?  Once you click the green "+" sign, and select the SUBSCRIBE widget, you then have to choose a layout.

     

    Once you choose a layout, the subscribe box and button is added to the page and will appear in the right side bar with that page's other sections.  You can then click on Subscribe in the sidebar and customize further.

     

    HTH! 😉

    Judith
    "Good things happen to those who hustle." ~ Anaïs Nin

    Hi

     

    Thanks for your reply.

     

    Yes I did this just like adding all of my other sections. all others  appear normal.

    I clicked on the Green Plus sign to add a "Subscribe" section. One tab allows me to enter the text. however , although the "Layout" Tab is visible and I can click on it, that section is completely blank. nothing for me to choose a layout for the subscribe section. no images to choose from etc.

     

    In addition there is nothing else for me to click on to add this section to my website.

    I guess Godaddy will have to assist me with this.

    Thank you in advance.