Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • GoDaddy Website Builders
  • GoDaddy Website Builders

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    Windows Platform

    When I upload html files everything works fine; site is accessible, but when I upload .aspx files I get this message...


    The application attempted to perform an operation not allowed by the security policy. To grant this application the required
    permission please contact your system administrator or change the application's trust level in the configuration file.


    I tried installing a trust tag in my webconfig file on level "medium" trust, but get the same message. When I set the trust tag level to "full" I get this different message...


    Cannot execute a program. The command being executed was "G:\PleskVhosts\\httpdocs\bin\roslyn\csc.exe"
    /shared /keepalive:"10" /noconfig /fullpaths @"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\


    I am at a loss for what to do. The "/noconfig" seems to be the problem; or at least what I'm surmising, but don't know how to correct if it is the problem, whether it's something I have to do to my webconfig or if GoDaddy has to correct. I've hosted many sites with different hosting companies but never had this problem. Anybody else had this issue and resolved? Your help will be greatly appreciated.

    1 REPLY 1

    I Found the problem. It wasn't what I thought, but close. It seems that GoDaddy's host, for whatever reason, is not compatible with the newer .net Roslyn compiler. (Maybe GoDaddy should update their Windows Servers??? Hint, hint!!) That's the folder inside the Bin folder that is in the newer additions of .net framework. Here is the solution for anyone else who may have this problem. If you are using Visual Studio, you need to click on "Tools>Nuget Package Manager>Manage Nuget Packages Solutions." Once there you will see to the left, the name of the compiler that your solution is using. The one that doesn't work in GoDaddy is... "Microsoft.CodeDom.Providers.DotNetCompilerPlatform.1.0.7." You should see that listed. You should also see a previous version there as well, at least I did. If you don't see a previous version, look to the right side of the screen and you will see a drop-down box with a list of previous versions. The one I used that is working is "Microsoft.Net.Compilers version 2.4.0", this is also the one that was listed under the CodeDom Compiler on the left side. You need to check the box for the CodeDom Compiler and click uninstall. This should automatically install or re-install the version 2.4.0. This should fix your problem, because it worked for me. However, this is an older version and is not compatible with C# 6.0. I am not running MVC, but you may find issues if you are running an MVC project because I believe it utilizes C# 6.0. If you are running an MVC project you might want to go to either Azure, which I hated, or, or some other hosting company who specializes in .NET Framework to host your sight. I had very good success with Discount ASP.Net, but was trying to save some money with my newest website. We'll see if GoDaddy will be sufficient for me because I am not utilizing any C# 6.0 features, at least not yet. If not, I will certainly go back to DiscountASP.NET. Azure sucks, unless of course, you are an expert with the Azure platform. There is no support other than the community, which is a very good community, but sometimes you need to speak to someone immediately, not so with Azure. DiscountASP.NET only has a community and email support, but they are very fast in getting back to you. All our problems would be solved if GoDaddy would update their Windows servers, although I don't want to complain too much because they are one of the best prices for Windows hosting, and I do like the Plesk Dashboard. It is better than DiscountASP.Net and Farrrrr better than the confusing Azure platform. I could never figure that one out at all. And don't let Azure fool you. You pay for what you use, but the price seems to add up very fast. One more thing. Don't forget to re-upload your webconfig, because that is going to change automatically with the new compiler. If you don't upload it you will get an error message because the old one is still in your root folder. Also empty you Bin folder in the Plesk File Manager and upload the new files from your Visual Studio Bin folder, because the Roslyn file will be gone and other .dlls will also be updated. Hope this helped!!