• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    New

    Cloudflare CDN + Managed Wordrpess + DNS problem

    Hi,

     

    I'm using Cloudflare as CDN for my domain(let's say foo.com), I added a record to Cloudflare which points(proxied) foo.com to the ip address provided in Managed Wordpress settings. From Cloudflare to Godaddy it becomes a proxied connection, that's why the ip address is not shown to Godaddy while it's trying to verify the DNS records. Because Godaddy can not see my DNS records, it blocks foo.com to reach to the ip address.

     

    It really blocks a very simply configuration, why does Godaddy even needs to verify the DNS records? Will there be a fix to this issue?

     

    Thanks

     

     

    1 ACCEPTED SOLUTION

    @sakir 

     

    The system shouldn't stop working unless CloudFlare is trying to connect with HTTPS.

     

    There are a couple of things going on here so let me start from the top....

    1) You SHOULD NOT use the proxy service from CloudFlare with Managed WordPress

    CloudFlare is both a proxy service and a caching service - what happens in this case is that you have a cache of a cache meaning that if you update content you might have to clear caches in multiple places to get the content to display correctly.

     

    2) SSL with Managed WordPress - GoDaddy does not support 3rd party SSL Certificates on the platform - If you do not have an SSL certificate installed (typically due to a lower end package) then port 443 is NOT enable / configured for the site and therefore trying to use external SSL to connect to the site could break the connection.

     

     

     

     

     

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post

    5 REPLIES 5
    Super User IV

    @sakir 

     

    I would actually recommend NOT using this configuration - GoDaddy has it's on caching on Managed WordPress and there is no way to disable it, by using Cloudflare you are double caching. 

     

    If you are referring to validating for the purposes of an SSL certificate you should just need to add a TXT record. 

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Hi @PL281 , thank you for your message. Actually, I disabled CDN in Godaddy WP Managed. Is there any other caching are you referring to?

     

    May I ask what do you mean by TXT record and SSL?

    @sakir 

     

    The Managed WordPress platform has built in caching. You were saying that WordPress was not seeing the domain hence I was asking what you were attempting to do. 

     

    You still need to add the domain in the WordPress management panel (GoDaddy - not WordPress itself) then pointing to the IP should work fine 

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    @PL281thank you for your response. When I set up an A record without a proxy through Cloudflare, everything is alright. But then, I don't have the possibility of using Cloudflare as proxy. When I change the A record as a proxy A record in Cloudflare, the system stops to work after a couple of hours due to Godaddy is keep trying to verify the DNS records.

     

    In my humble opinion, if I'm setting up a domain at Godaddy Managed WP, it doesn't have to verify if my DNS records are valid, it's rather my issue to point out correctly.

    @sakir 

     

    The system shouldn't stop working unless CloudFlare is trying to connect with HTTPS.

     

    There are a couple of things going on here so let me start from the top....

    1) You SHOULD NOT use the proxy service from CloudFlare with Managed WordPress

    CloudFlare is both a proxy service and a caching service - what happens in this case is that you have a cache of a cache meaning that if you update content you might have to clear caches in multiple places to get the content to display correctly.

     

    2) SSL with Managed WordPress - GoDaddy does not support 3rd party SSL Certificates on the platform - If you do not have an SSL certificate installed (typically due to a lower end package) then port 443 is NOT enable / configured for the site and therefore trying to use external SSL to connect to the site could break the connection.

     

     

     

     

     

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post