• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 
    Go to solution
    New

    Frustrating SFTP Upload Failures

    Can this please be fixed!

     

    I am familiar with FTP/SFTP. I used Filezilla and I cant even upload a single file.

    Am I not paying for such feature, why is it restricted?

    In the end I installed a File Manager plugin to access the root directory, as there's no cPanel or equivalent available.

     

    What's the non-technical fix?

     

    I don't want disable this, enable this, reset that... it should just work! 

     

    I've been a WordPress user for several years, but never on GoDaddy and never I have experienced this.

     

    It's not fine, so don't pretend it is.

    Fix!

    14 REPLIES 14

    Re: Frustrating SFTP Upload Failures

    Exact same issue...everything keeps timing out. Clearly server-side, but the Status page indicates everything's fine. However, DownDetector.com indicates there are outages all across the USA. Who's got the credible information? When will we see a fix?

     

    I had hoped there was a way to get support without sitting on a telephone all weekend, but that looks like the only option.

    Re: Frustrating SFTP Upload Failures

    The SFTP indeed annoying, i can't even upload files, only can download files.

     

    If the issue can't be solve, I'll gradually move all my websites hosted at godady to other hosting.

    Helper IV
    Helper IV

    Re: Frustrating SFTP Upload Failures

    Hi @ramjam @dialoghub @seekonksaveapet

     

    To log in through FTP (FileZilla).  You should know the primary credentials of your web hosting.  Follow the video tutorial below.

     

    https://youtu.be/J2ai0HvMVd8

     

    Thank You.

    Re: Frustrating SFTP Upload Failures

    @manojkumarcdo not sure how that video relates to our problem...

    Helper IV
    Helper IV

    Re: Frustrating SFTP Upload Failures

    Hi @cdmyursar,

     

    Actually, I thought that video will help you to understand some basic credentials that you have to know.
    I apologize for that. 
     
    Follow the link below. 
     
    Thank You.
    New

    Re: Frustrating SFTP Upload Failures

    Same problem. -- I can download but not upload even a single small file. Very frustrating!

    Re: Frustrating SFTP Upload Failures

    Since I registered an account the major problem I encounter is synchronisation of changes, upload of files with FileZilla and the overall usability is terrible. 24/7 support does not even work.

    With FileZilla, I'm able to download files, delete files, and even rename it but uploading only replaces the file with a zero byte file and sometimes with a file named ".nfs00000000*". I have been trying for weeks. I got it working today just for 1 hour by changing the name of the server to its IP address. That seemed to have solved the problem but my joy only lasted about an hour. After that,  the error "Network error: Software caused connection abort" started again. I just cannot upload any page to my WordPress hosted site.

    I want this problem solved as soon as possible.

    Re: Frustrating SFTP Upload Failures

    I was having the same issue, spent maybe 30-45 min on the phone with a very helpful support tech who says everything looks fine on their end. He asked if I could try from a different network and so I ended up setting up a wifi hotspot from my phone and testing it and that worked, which told me it was something local to my network. 

     

    The first thing that came to mind was setting up a port forward for sftp and that did the trick. For some reason my router didn't want me uploading files via sftp, I could download and view the directory fine, but not upload. 

     

    Hopefully this helps other people who may be having similar issues... there are a million different ways to port forward, so I can't really give specific directions there, but recommend googling your router and finding resources for forwarding port 22.

     

    Goodluck! 

    Re: Frustrating SFTP Upload Failures

    I was having this same exact issue as well, until I found the solution here:

     

    https://www.godaddy.com/community/Managed-WordPress-Hosting/Solution-SFTP-Upload-Issue-with-Managed-...

     

    Basically, it had to do with the power management settings on the NIC.  I disabled all of the power-saving options and have been able to upload large files with no problems ever since.

     

    Hope that helps!

    Re: Frustrating SFTP Upload Failures

    Still no fix and GoDaddy refuses to acknowledge this as an issue.

    TW+CO | Branding, Web Design + Creative Direction for Lifestyle Brands | tierrawilson.com
    New

    Re: Frustrating SFTP Upload Failures

    Yea I read the post where the solution was. I have to enable/disable the NIC even though it says the file failed. At least it transfers. So i just have to do that enable/disable the NIC

     

    Godday please look at this issue.

    Re: Frustrating SFTP Upload Failures

    I too have the same issue on Wordpress Managed Hosting, my site has to many redirects errors, SFTP does not work on Filezilla or command line. Tried from different locations & different service providers but makes no difference, the issue/fault is with GoDaddy. Compensation is in order!
    New

    Re: Frustrating SFTP Upload Failures

    It sounds like the solution is in either changing the port that the upload goes through or turning off power limitations with the networking adapter.

     

    Could people who believe they have found a lasting solution please give us an update?

    Solution

    Re: Frustrating SFTP Upload Failures

    I could not  believe it being a NIC card power issue on my computer, but thank you so much for discovering the fix.

     

    I did the temporary fix on my Win10 PC and it started working.. If you right click your network connect in the task bar you can access the network setting of your machine as well. Below is all I did and started to work!

     

    Temporary Fix

    If you disable then re-enable the network device under:

    Control Panel > Network and Internet > Network Connections > Disable this network device

     

    Permanent Fix

    The settings you see for each device will depend on the device and its driver.

     

    DEVICE DRIVER SETTINGS

    Control Panel > Network and Internet > Network Connection

     

    For my wireless USB NIC card

    • Right click on the NIC card device
    • Properties > Configure > Advanced >  Selective Suspend > Disable
    • Properties > Configure > Advanced > Power Management > Allow the computer to turn off this device to save power (uncheck)

    For my hardwired PCI Express NIC card

    • Right click on the NIC card device
    • Properties > Configure > Advanced > Power Management > Allow the computer to turn off this device to save power (uncheck)

     

    POWER PLAN OPTIONS

    • Control Panel > Hardware and Sound > Power Options
    • Balanced (recommended) > Change plan settings > Change advanced power settings
    • Wireless Adapter Settings > Power Saving Mode > Maximum Performance (battery & plugged in)
    • USB Settings > USB selective suspend setting > Disabled (battery & plugged in)
    • PCI Express > Link State Power Management > Off (battery & plugged in)