• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Super User II Super User II
    Super User II

    Managed WordPress Memory Settings

    What are the GoDaddy default Memory Settings for Managed WordPress?

    What does GoDaddy recommend as the best way to modify?

    What is the top allowed memory limit?

    Why is my site 40M memory when I have the user ini set to 1024?


    Hoping someone from GoDaddy can advise officially on the above.

     

    BACKSTORY:


    After the 4.7 / PHP 5.6 upgrade all my sites have been wonky -- 502s, 503s, white screens, timing out and Notice: Indirect modification of overloaded element of WP_Hook has no effect in /home/content/xxxxxxxxxxxxx/83/3045183/html/wp-content/object-cache.php on line 664

     

    Apparently there is a known issue with 4.7:

    WP 4.7, object-cache file breaks the site if APC is not enabled in php

    Seems others on GoDaddy are having the same issues identified on WordPress.org.

     

    Switched to 2017 theme still had issues. Disabled all plugins nothing changed. Ran the debug file -- nothing there to indicate what is going on. I have sites on other platforms with identical setups (one with even more plugins!) and no issues.

     

    When on the phone for over 2 hours last week I was told there were known server issues GD was aware of and "working on" but could not get any further details. (Nothing was mentioned about this on the network status page.) I was also told this could happen in a shared environment -- the default we don't know what is going on excuse. How "shared" are we? These very same sites never had any resource issues on HostGator standard shared hosting...


    The reps I spoke with were not aware of the known WP 4.7 issue (that will be resolved in 4.7.1) that is producing the above WP_Hook error and performance issues. I did notice that the object-cache php file was disabled by the tech I spoke with.


    So it's not the themes, not the plugins -- all I've got is memory and resources. Changed the wp-config to 256M seems a little better but still temperamental. Errors I've been tracking all seem to be memory/resource/connectivity related. Being the memory issue has come up in the forums the past several weeks as well as elsewhere, getting GoDaddy's POV on this would be helpful.

     

    TIA!

    Judith
    "Do one thing every day that scares you." ~ Eleanor Roosevelt

    12 REPLIES 12

    Re: Managed WordPress Memory Settings

    I think am having the same issue. I get a "Indirect modification of overloaded element of WP_Hook has no effect in /home/content......" in my Theme Options, under Appearance. For the last 4 days, I have not been able to adjust any theme settings because I get that Indirect modification error and have no access to my Theme Options (my themes general settings) and it times out. But so far everything else in the dashboard I seem to have access to.

    At first, I thought it was the theme because I had recently updated it. But I deleted it and reinstalled. Same issue. I then restored my wordpress to before I updated the theme. And I still had the issue, so that confirmed it was a hosting issue. I then went on the Wordpress forums. And multiple people on Go Daddy Wordpress mentioned they were having this issue. I was thinking about calling Go Daddy tonight but if they are aware what is the point? There is nothing we can do to fix it right??


    Highlighted
    Product Team
    Product Team

    Re: Managed WordPress Memory Settings

    @Muse @karadavis26

     

    Thanks for posting--it's not just you.  The issue doesn't have to do with memory settings, so you can leave those default, it's an issue with a recent platform update.

     

    To support the PHP 5.6 upgrade, we upgraded the caching tier to Redis.  Unfortunately, this is causing performance issues in some datacenters, which is what you're seeing.  We're working on a fix now with the goal of rolling it out in the next week or so along with the rest of the PHP 5.6 upgrades.

     

    I'm sorry about the issues it's causing for you, I know it's frustrating and you guys deserve a lot better.  Thanks for hanging in there, we're working as fast as we can to resolve this.

     

    Thanks,

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy
    Super User II Super User II
    Super User II

    Re: Managed WordPress Memory Settings

    @Gabe  Thanks for the update.  Maybe you can pass that along to the tech support folks?  They did nothing but claim it was my sites -- when I could prove differently.  Including adding a new install that  was whitescreening right from the GoDaddy dashboard trying to get into WPAdmin -- with no themes or plugins...

     

    Can you keep us posted?  Thanks!

     

     

     

     

     

     

    Judith
    "Do one thing every day that scares you." ~ Eleanor Roosevelt

    Product Team
    Product Team

    Re: Managed WordPress Memory Settings

    @Muse Sorry about that, yeah, I'll pass it along.  I'm not great at checking these forums, so feel free to tag me with any questions so I'll get an alert.

     

    Thanks,

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy
    Helper I
    Helper I

    Re: Managed WordPress Memory Settings

    It would be really great if tech support knew this information. I've been getting the runaround for a few weeks and being told that whatever issues were happening have been resolved when they were actually not...

    Re: Managed WordPress Memory Settings

    Hi Everyone, I had the same error message. I did the Online chat with someone by the name of Elmer a few minutes ago. I was having the same error message that is mentioned above ,and he fixed it. I asked him how he fixed it and he said, "I ran a test and edited the cache".  

    Re: Managed WordPress Memory Settings

    I spoke with Terra on the live chat feature and they were also able to fix the issue by having "disabled object-cache.php".

    Re: Managed WordPress Memory Settings

    Yikes.  SO glad I found this thread, since GoDaddy support was telling me nothing was wrong and I was getting a whole slew of bizarre errors that weren't reproducing consistently.  Then I disabled object-cache.php and ALL the error messages went away.  Now the tech support guy is telling me that it must be related to GoDaddy's update of the PHP version on their managed WP environment..  If anyone hasn't seen it, I think this thread may also be relevant - https://www.godaddy.com/community/Managing-WordPress/Wordpress-Managed-PHP-Version/td-p/3292/page/4

     

    Re: Managed WordPress Memory Settings

    Hi Gabe, Just curious when the Wordpress Managed Hosting Team would be repairing the issue with Memory Configuration to fix the issue with "

    "Indirect modification of overloaded element of WP_Hook"

    I get the error notification on a client's site every week.

    The exact error reads: "

    BackUpWordPress detected issues with your last backup.

    • php: Indirect modification of overloaded element of WP_Hook has no effect, /home/content/p3pnexwpnas07_data03/66/2853366/html/wp-content/object-cache.php, 709

    Re: Managed WordPress Memory Settings

    does anybody know how to increase WP memory?

    Super User II Super User II
    Super User II

    Re: Managed WordPress Memory Settings

    @smartsolution

     

    Add this line to your wp-config.php file:

     

    define( 'WP_MEMORY_LIMIT', '256M' );

     

    More info on this file and memory here.

     

    HTH! Smiley Wink

    Judith
    "Do one thing every day that scares you." ~ Eleanor Roosevelt

    Re: Managed WordPress Memory Settings

    Hi Guys, when i add define( 'WP_MEMORY_LIMIT', '256M' ); to my wp config ,y site is not loading anymore.

    I get HTTP ERROR 500 any ideas why?