Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, August 4th at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Helper III
    Helper III

    Solution: SFTP Upload Issue with Managed WordPress

    Hi Everyone,


    Problem: Uploads Failing on PUT (SFTP)

    File uploads were consistently failing on file transfer to Managed WordPress hosting using SFTP protocol with FileZilla or Dreamweaver. The issue was so troublesome to diagnose, it took months to nail down so I thought to share the solution in case anyone else finds they are having the same issue.


    Wired & Wireless Reduced Power State

    The issue occurs both with hard wired & wireless NIC cards, the cause being the reduced power state the cards are placed into by the Windows OS power plan on their USB & PCI Express buses plus the device driver settings.  


    Solution:  The fix is to alter the power plan & device driver settings to prevent the NIC cards from entering a reduced power state so always allowing the NIC cards to properly negotiate uploading (PUT) files with the Linux GoDaddy server cluster using SFTP.


    Computer Setup

    • Windows 10 Pro OS (64 bit)
    • Desktop Intel i7-2600 CPU @ 3.40GHz
    • 12 GB RAM
    • Network Cards
      • Realtek PCIe GBE Family Controller NIC card (RJ45 connector, hardwired)
      • 802.11ac Wireless LAN Card (Netgear AC1200 High Gain WiFi USB Adapter)
    • NETGEAR Nighthawk X4S AC2600 Smart WiFi Router (R7800) - New replacement router
    • CISCO (Linksys) E4200 Router - Old original router
    • FileZilla & Dreamweaver CC (SFTP clients)


    Reduced Power State of NIC (Network Interface Card) 

    When your NIC card enters a reduced power state controlled by the NIC driver setting and the Windows OS power plan (USB & PCI bus settings) this for some reason messes up the upload functionality of SFTP, even as the download functionality works without problems.


    You can download files but not upload them, which drives you crazy...


    Symptoms of Upload Failure

    The SFTP client tries to upload (PUT) a file but a zero 0KB stub file name is instead created together with a temporary server side file in the format .nfcxxxxxxxxxxxxxxxxxxxxxxxx where x=various random numbers.  Once the temporary transfer file is created this breaks all further attempts to upload anything and it must be deleted from the server to enable transfers to continue.



    somefile.html - 10KB (local)   =PUT=>   somefile.html  - 0KB (server)

                                                   =====>   .nfc0903490243214324343243


    Temporary Fix

    If you disable then re-enable the network device under:

    Control Panel > Network and Internet > Network Connections > Disable this network device


    The upload functionality would start working for a while but after an hour or so would apparently randomly stop working.  I now know this is due to the device on its PCIe / USB bus being placed into a reduced power state when not in use by the operating system.


    Permanent Fix

    The settings you see for each device will depend on the device and its driver.



    Control Panel > Network and Internet > Network Connection


    For my wireless USB NIC card

    • Right click on the NIC card device
    • Properties > Configure > Advanced >  Selective Suspend > Disable
    • Properties > Configure > Advanced > Power Management > Allow the computer to turn off this device to save power (uncheck)

    For my hardwired PCI Express NIC card

    • Right click on the NIC card device
    • Properties > Configure > Advanced > Power Management > Allow the computer to turn off this device to save power (uncheck)



    • Control Panel > Hardware and Sound > Power Options
    • Balanced (recommended) > Change plan settings > Change advanced power settings
    • Wireless Adapter Settings > Power Saving Mode > Maximum Performance (battery & plugged in)
    • USB Settings > USB selective suspend setting > Disabled (battery & plugged in)
    • PCI Express > Link State Power Management > Off (battery & plugged in)



    Add into the mix I had my router setup with a "dial on demand" setting to the DSL modem which I changed to be "permanently connected" to reduce any potential for dropping connectivity during negotiation.  I did not confirm this was a definite contributing cause but mention in case it is relevant for someone else.


    What didn't work

    • Changing NIC cards, didn't fix the issue.
    • Reinstalling device drivers, didn't fix the issue.
    • Windows 10 reset all network connections, didn't fix the issue.
    • LAN connectivity, wireless versus hard wired, didn't fix the issue.
    • Changing routers, didn't fix the issue.
    • (The modem could not be changed being custom programmed by our ISP).
    • Using different SFTP clients, didn't make a difference.
    • Resetting the NIC device, temporarily fixed the problem.
    • Only by changing the power state options, was the issue permanently fixed.


    Community Manager



    Thanks so much to all of you for participating in this thread. We were finally able to identify a small configuration change that we were able to put into effect to help with this situation. Basically, we had to allow smaller blocks of data to be transmitted, which allowed a more stable connection. That should resolve a majority of what you were all seeing. However, please don't hesitate to reach out to our support team if you continue to have this issue. 


    Special thanks to @Aly for helping us identify and troubleshoot the issue Smiley Very Happy


    JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give likes.

    View solution in original post

    40 REPLIES 40
    Helper III
    Helper III

    The other weirdness was while the issues were happening with Managed WordPress I was able to upload securely using SSH and FTP (Dreamweaver & FileZilla) to our other GoDaddy hosting account.  Somehow the secure protocols were being negotiated differently between hosting servers and the NIC cards or the hosting servers have a different communications setup.


    The NIC cards were not coming out of the low power state fully (for some reason) and being able to negotiate and send via SFTP.  This was the strangest problem and nothing to do with bad router hops or internet connectivity for the issue continued during testing over several months.  If you reset the NIC card (disable/enable) then it would work on the same trace-route path a moment later.


    Hope this helps someone for it frustrated me for a long time.

    Helper III
    Helper III

    The upload problem has returned and the solution previously provided no longer works.  I think there may be a more general underlying issue with file uploads to Managed WordPress hosting as indicated in the following post.




    The issue is duplicated on other computers in our company so less likely now to be individual operating system settings.  We do not have a permanent solution at this time but we do have a workaround that still functions.


    Disable the network adapter, allow it to fully disconnect then re-enable the network adapter.


    The file upload will then work for a period of time, maybe good for up to 30 minutes but it varies, where a moment ago it would not, on the same computer, router, modem, ISP and router hop Internet connection setup.  The only change is the network adapter reset.


    Different computers, different network adapters and device drivers... same issue.


    This assumes the temporary .nsf files have first been cleared.


    Thanks for your extensive explanation. Do you have any ideas why this is happening only on Godaddy's managed WordPress hosting?


    I am using multiple hosts and FTP clients and never had an issue like this. Also, it seems the problem is confined only to larger files (multiple MB+). Transfer of small files works just fine.


    Btw, I managed to by-pass the issue by avoiding using a wireless connection. Connecting my laptop via a cable seemed to have worked.

    I'm so glad you put trying a wired connection!!! You just saved me!


    Thanks again!

    Helper III
    Helper III

    This problem continues unfixed.  Various people made some good suggestions that I tried on my NETGEAR router.


    1. Setup port forwarding on port 22 from the fixed IP address of the computer attempting to SFTP with the transfer protocol TCP.
    2. Setup QoS (Quality of Service) to restrict the upload data rate in case the data was being sent too fast causing a drop out, used 1Mbps upload.
    3. Firmware update to the latest version for my router in the hope there may have been an internal protocol bug fix.

    None of the above did anything for the problem.  The only very temporary workaround I'm finding is to disable/re-enable the network adapter and that lasts for just a few minutes before the upload hangs but it gets the job done.


    So the essential question is why would resetting the network adapter make any difference? Rebooting the router itself doesn't fix the issue so what is being changed between the computer using the SFTP protocol, the local router and GoDaddy's FTP servers?


    My only non-expert thoughts are when the local computer first connects to the local router there is a "clarity of connection" (whatever that actually turns out to be) that allows the SFTP using TCP protocol to properly negotiate with GoDaddy's servers the first time.  Then after a short time period the local computer to router to GoDaddy server packet exchange loses this clarity of connection.


    Does anyone with a more expert understanding of protocol negotiation have any better informed understanding?  I have tried WireShark and can't see anything, just a non-negotiation of connection and timeout of connection.


    Maybe this is a locally sourced issue but it appears to be affecting a whole bunch of people.  How can we figure out a local versus server based problem?




    I have two problems.


    Using Filezilla:  software disconnects.  Changed settings, port 22, Here is the exact error:

    "Response: fzSftp started, protocol_version=8
    Command: open "" 22
    Error: Network error: Software caused connection abort
    Error: Could not connect to server"


    Waiting on chat now, but do not get it.  We received an email mssg from Google the site had been hacked.  I checked the suspicious posts in WP, found nothing,  attempted to use Filezilla.  Yesterday was logged in for a minute through Filezilla after four attempts with the first error mentioned above.  Next four attempts same error.  Ran out of time, left it for today, hence the following issues mentioned. 


    The real issue with GoDaddy SFTP is that their connections aren't capped at a reasonable rate. So if you connect and it starts downloading at 8 MB/s, it is gonna close the connection in an attempt to rate limit, I guess. Anyhow, if you cap your DL speed on your client to something reasonable, say 2 MB/s, the connection holds and downloads just fine.



    The fact that you posted this and GoDaddy has not realized it is the ACTUAL solution, and they highlighted that bogus explanation above that basically puts the fault on the client instead of their server settings is crazy to me. The least they can do is provide their clients with the right SFTP settings needed if the standard settings are not working like every other site. I tried what you suggested and it absolutely worked perfectly in Filezilla. Thank you for posting this.

    Getting Started

    I am having this same exact issue. What finally worked for me was disable/enable the NIC. I even called godday support and on their end it works just fine. I did more digging after the call and found your post. Since they cant reproduce the issue they kept saying on my end. Man this was like super frustrating just to modify one dam file. I even used winscp and another computer. Internet fine from work and home. both file transfer clients working fine. Its still not really resolved. It says the file didnt transfer but it does transfer. This makes no sense.


    Thanks for this post. It gave me some things to try even though it randomly works and then it stops again. I just have to keep disabling/enable the NIC to kinda make it work.


    Godday needs to look at this.






    I Have called TECH SUPPORT? 3 times, for SAME ISSUE.




    ARE YOU ON CRACK!?!?!??!?!



    Helper III
    Helper III



    Don't rain your fire down on me, I'm just trying to find a solution to this problem.  The information I put out there was done with the intention to help resolve or at least workaround the issue.  Take up your issue with GoDaddy directly.

    Ya that was not directed at you at all.
    Only GODADDY
    Solutions I've found:
    1. worked once only :  disable / enable network adapter
    2. worked once : install brand new install of filezilla on different computer (may work more)
    3. wait : worked once

    What did not work.
    1. call support : has not worked and has been a giant waste of time (when usually it is not)
    2. Installing another FTP client on 'same computer'
    3. getting angry and stressed out : did not work

    Have a productive day.
    I am wishing I had the last 4 hours back.

    Helper III
    Helper III



    OK thanks, sorry you are having this issue, its still happening for me too and I'm beyond fed up with having to work around it day-to-day.


    So I have investigated some more (as I get time).  Here is what I have found out about the .NSFxxx temp files that are left on the server once the upload process fails.


    What are .NSF Files and Why they are created?



    Basically according to the above links, under linux/unix, if you remove a file that a currently running process still has open, the file isn't really removed.  So it looks like the upload process is:


    1. Starting the FTP upload
    2. Failing Mid-way (for whatever reason is effecting everyone)
    3. The FTP upload process is left open
    4. The uploaded temporary file is removed (???)
    5. Causing the .NSFxxx file to be left on the server
    6. Having the .NSFxxx file on the server then prevents any future FTP upload connections from being negotiated until you manually clean up the mess

    When I get some time I'll research negotiating FTP server upload protocol negotiation to see if that knowledge gives me any clues.




    Fantastic. Thanks! This finally sorted it

    Helper III
    Helper III

    Hi Everyone,


    I have officially given up trying to use SFTP with Managed WordPress Hosting and simply bypassed the problem by installing a file manager plugin that can upload any and all files at all times without problems.


    Take your pick of file manager plugins from the WordPress repository.


    GoDaddy after nearly six months of trying to make this work my conclusion is that your SFTP file uploads service is unreliable, undependable and quite useless.  The only pattern I can discern is during high capacity time periods it fails to upload and during lesser capacity periods the chances of uploads working are much higher.


    From this observation I am going to suggest that lack of capacity to accept and negotiate good SFTP upload connections via your FTP servers is a factor in the problem.  For why would it work at any time if the negotiated connection was impossible to make via our computers, routers, modem setup?  This is an observed pattern over MONTHS and not just a one off bad ISP router hop connection.


    Downloads have always worked flawlessly at any time of day.



    Hi, Aly,


    I can confirm your conclusion that GoDaddy SFTP with Managed WordPress and Windows 10 has serious issues.


    I am a web developer who has installed hundreds of WordPress sites on  GoDaddy servers, and have no problems with those I install WordPress on Linux CPanel servers which are great, but any site I've built on Managed WordPress suffers the same SFTP problems you describe.


    SFTP will work for a while, but after a while returns "fatal errors" when you try to transfer files, and usually writes the file you are sending onto the server with 0 bytes -- no content in the file now on the server -- which in some cases can crash your WP site if you are uploading something like a WP-Config.php file etc.


    The only way to remedy the problem as you describe is to disable your network adapter in Windows Device Manager and then renable it, after which it will work again for a while until it crashes later in the day.


    It doesn't matter which FTP program you try to use, whether FileZilla, Dreamweaver, etc. the errors are the same. And it doesn't seem to matter which PC or network card I use -- I have tried many -- and I get the same result.  And you can't blame the problem on your ISP or router because I upload files from many locations where my clients are, but I have the same problem regardless of which WordPress site, PC, network card, router or ISP is being used.


    The problem not only affects SFTP transfers, but can also screw you when you are simply using the WordPress Admin to manage or edit your site. When you try to Save a page, you will often get a timeout error and your page isn't saved, and you always lose your work in your WordPress editor when it crashes.  Also, when saving a page or post in WordPress admin does complete successfully, it still takes far longer to send and save the page as it should. It's fast on Linux servers but really slow on Managed WordPress.


    I have called GoDaddy tech support but of course they just blame this on your ISP or network or tell you there's some hardware problem on your PC, even after you tell them you've tried many PCs and ISPs. I have spent days trying to figure out how to change settings in Windows 10 to avoid the problem. It has to be an OS problem because it doesn't matter which program I use to try to SFTP. It is not a network wireless card problem; installing the newest network card doesn't make the problem go away.


    Managed WordPress server data transfer is so unreliable with Windows 10 that I have had to move entire WordPress sites off Managed WordPress and onto Linux CPanel servers just to avoid the problem. There are 0 problems with data transfer or saving pages on CPanel servers at GoDaddy (I have hundreds of sites on them) but every site I've tried to build on Managed WordPress has been problematic, and I have tried a few.


    This problem has been around a long while. I was hoping it has been resolved by now, so I just tried installing a client site on Managed WordPress again, but I am now going to have to move it off Managed WordPress and onto Cpanel because of the data transfer issues.


    You are not alone, Aly.


    Jonathan at





    I confirm I have ALL the same problems as ATLWebDesignGA including those where simple saving in wpAdmin and even browsing the site can occasionally result in "This site can’t be reached" message. I was afraid this was happening for all users accessing the site, but I guess not (or maybe it is, I don't know at this point). So frustrating!


    HOURS spent diagnosing and troubleshooting and HOURS more on the phone with GODADDY net NO SOLUTION.


    Uninstalling/reinstalling my network adapters via Device Manager seems to have mostly resolved the issue (THANK YOU). I can upload files successfully at a higher rate, but nowhere near normal. I do not expect it to maintain.


    Side note - I also have a "VirtualBox Host-Only Ethernet Adapter" in Device Manager Network Adapters. Is anyone else running this, possibly causing conflict? I'm not savvy with this stuff, just a shot in the dark.


    Godaddy Managed Wordpress


    Windows 10
    Netwrok Adapters: Intel(R) Ethernet Connection I218-V
    Realtek PCIe GBE Family Controller

    ISP: ATT

    Community Manager



    Thanks everyone for taking the time to look into this and share your issues/resolutions. This can definitely be a frustrating issue. From this end, I can tell you that it is possible (in isolated situations) for the cause of the upload problem to be something on our end. However, it is also entirely possible for the cause to be related to things like network cards, firewalls, and many other variables. Unfortunately, there's no silver bullet for resolving this issue. The key thing to know is that each situation needs to be reviewed on a case by case basis. Here are some common troubleshooting steps you can take to move forward.



    As has been expertly detailed by @Aly and others, there are some network components that can come into play with this situation. These are all excellent troubleshooting steps to try. For some people, they work. However, when they don't, please consider other additional troubleshooting steps.



    This may not be an issue for anyone on this thread, but making sure that you're using the correct protocol and port (SFTP/22 vs FTP/21) are essential in uploading files.


    Session time out


    SFTP sessions do not stay open indefinitely. A good practice is to refresh the directory you're currently in with the client software so the connection can be re-established if it was disconnected. Coming back to a connection that has timed out will cause connection failures.


    Contact Support

    If none of the steps above (including those posted by others) help to resolve the issue, please get in touch with one of our hosting support representatives. Please be sure to let them know you've tried the steps above. Also, I'd recommend having the following information ready:



    JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give likes.

    @JesseW -  I have moved several of my clients to Managed Wordpress and I am experiencing this issue only on one. I have shown this to tech support when I called. There's nothing wrong with your Nic card, nothing wrong the firewall. I am able to connect and upload/download using the same windows 10 PC on several other Managed Wordpress account while I am facing this issue with this one particular account.  

    It seems like tech support is not looking into resolving this issue. 

    Helper III
    Helper III

    Hi Jonathan,


    Thanks for giving some confirmation of the same issue that I have been experiencing.  The fact the problem is happening over a wide number of ISP's, operating systems, modem, router combos adds weight to the argument this is not a local user problem.


    OS Specific Issue?

    You have a good thought on the issue being operating system based for as with you, no matter which file transfer client I used the problem was the same.  I wish it were just a Windows 10 OS problem but it also occurs on our Windows 7 OS built computers.


    OS Test on Linux or Mac 

    A really good test is if someone reading this thread is using a Linux based OS or a Mac OSX computer do they have the same SFTP negotiation issues with Managed WordPress Hosting (MWH)?  That would help narrow down if this is OS restricted or a more general problem.


    Any Mac OSX users out there want to give this a try and post their findings?  Apple gear is too expensive for me to buy just for this testing purpose.


    Windows Network Stack Issue?

    Could this be a more general network stack issue with Windows OS computers and the SFTP protocol negotiation being used by GoDaddy's MWH servers? 


    If Windows 10 or 7 computers can consistently negotiate SFTP correctly with cPanel then I am inclined to think there has to be a difference in protocol negotiation and/or ports used that causes the failure with MWH servers.


    SFTP Protocol Negotiation Differences - cPanel / MWH


    What would really help to know is the difference between cPanel and MWH and how those servers are setup to negotiate SFTP on the back-end of GoDaddy.


    If negotiation works one way but not the other can they modify how the MWH servers are configured and so give everyone a permanent solution?