Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    NonTechGuy
    Getting Started

    Staging site getting SSL error

    Hello all,

     

    I recently started a staging site intending to test PHP upgrading, but the staging site keeps returning this error to me:

     

    Staging error.png

    My production site is working fine, and everything is synced. Does this mean I need to buy a SSL certificate for a staging site too? 

     

    Thank you.

    1 ACCEPTED SOLUTION
    PL281
    Super User IV

    @NonTechGuy 

     

    As of right now the staging site (and temp urls - a.k.a. myftpupload.com) do not include SSL 

    You might have a plugin forcing SSL - so you might have to manually disabled that via the database

     

    Look for active_plugins in the options table and set it to  a:0:{}

    That will disable all the plugins and then you can just enable the ones you need

     

    If that still doesn't fix the issue of getting to the site without HTTPS, then check the wp-config.php for a force SSL with a value of 1 and change it to 0

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post

    1 REPLY 1
    PL281
    Super User IV

    @NonTechGuy 

     

    As of right now the staging site (and temp urls - a.k.a. myftpupload.com) do not include SSL 

    You might have a plugin forcing SSL - so you might have to manually disabled that via the database

     

    Look for active_plugins in the options table and set it to  a:0:{}

    That will disable all the plugins and then you can just enable the ones you need

     

    If that still doesn't fix the issue of getting to the site without HTTPS, then check the wp-config.php for a force SSL with a value of 1 and change it to 0

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post