• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Highlighted

    Unable to install or update plugins (Update Failed: -1)

    Good day ladies and gents!
    As I was trying to update 4 plugins on my WordPress website, I kept on getting the message "Update Failed: -1" every single time. I asked Godaddy's support team, and they don't seem to have a clue what is going on. so I went to a Facebook group asking experienced people if they have any idea on what might be the problem, a guy told me that it can be a "virus".
    To me, that looks like it because my caching plugin stopped working, my security plugin (WP Cerber Security) is not working either, I went to the access list, and I saw that there was an IP address in the "access lists" that's not mine, and the problem is, the REMOVE button can't seem to remove that IP address from the white list.
    If anyone here has any idea on what's happening, it would be much appreciated if you can point me in the right direction.
    Thanks in advance!

    4 REPLIES 4
    Super User III
    Super User III

    Re: Unable to install or update plugins (Update Failed: -1)

    Hey there @Omarijuana 

     

    This could actually be several things; database corruption, file corruption, or it could be malware.  What's the URL for your site? I can take a look on the surface of things and see if anything is weird.

     

    One thing you can do in the meantime is FTP into the file directory and try disabling the .htaccess file. Just rename it. That might do the trick.



    I am a GoDaddy End User - Just Like You
    * Please note that I offer free advice on this forum. I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community


    Re: Unable to install or update plugins (Update Failed: -1)

    Thanks for your reply @MrVapor.
    My website is ecommerceprophet.com/ it was fixed automatically yesterday without me doing anything. and after things were fine, I changed my password and login URL, I also installed Wordfence plugin and ran a scan, and nothing looks dangerous.
    I have Wordpress hosting, not cPanel hosting. But I have saved 3 versions of my .htaccess file over time, and I will replace the current one with one of the previous 3 versions if you think it's something serious after checking things out.
    I appreciate your help. Thanks a lot!

    Super User III
    Super User III
    Solution

    Re: Unable to install or update plugins (Update Failed: -1)

    Hi @Omarijuana 

     

    I took a look as well and found nothing out of the way or suspect on the surface. I did a little research on your issue last night and I think this was a server issue that was most likely temporary. I think the API Rest function wasn't communicating properly, which I have seen on occasion.

     

    I'll be honest, as someone who develops/designs WordPress sites, I loathe managed WordPress solutions, whether that be here at GoDaddy or any other host. They have a tendency to cripple your ability to add additional functionality in some areas and they always seem to run into issues. While you don't need a VPS, I would suggest moving to cPanel hosting instead. I always encourage people to get the low tier Business Hosting as I've been using it for a while now and it's superb. No sharing, like a VPS but without the headaches of server administration, and you're not limited by the platform.

     

    I'm glad it's working. If you need anything else, give us a yell!



    I am a GoDaddy End User - Just Like You
    * Please note that I offer free advice on this forum. I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community


    Re: Unable to install or update plugins (Update Failed: -1)

    @MrVapor how did you figure out rest api is not working?