Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    arunkumaran
    Getting Started

    WP Cron does not appear to be running in WP Hosting - Please fix

    Hello There,

    I am getting the WP Cron error on my WP Hosting, I am scheduling AutomateWoo, which is part of my GoDaddy package, as GoDaddy provide lots of WooCommerce premium plugin with Ecommerce WP Hosting, some of the plugin are highly depend on Wp Cron and due to the error I am not able to run or update the plugin.

    I have raised this with the support team and got advice to run Alternate Wp Cron or switch to Cpanel Hosting.

    I can accept the interim solutions, but the suggestion to switch to cPanel hosting is not the right way, as all the customer who purchase the Managed WP Hosting get the AutomateWoo and other WooCommerce plugin's  as part of package and GoDaddy should make sure all the plugin's are running correctly on your hosting.

    I can see lot of community forms on this issue and every form has the same suggestion to switch to cPanel hosting, if this is the only solution, I am afraid, should have not purchased Managed WP from GoDaddy, instead should gone with cPanel hosting :), then I will be loosing all the WooCommerce plugin which I got as part of E-Commerce Managed WP Hosting from GoDaddy.

    I cannot switch to Cpanel Hosting now, and any customer who bought the WP Hosting with all Plugin's may not willing to switch the hosting.
    This looks to be a long pending issue with WP Hosting from GoDaddy and should be fixed to run WP Cron job from Managed WP hosting sooner.

     

    Below is the error message.

    ✕ WP Cron does not appear to be running. This function is heavily relied upon by AutomateWoo. Please contact your hosting provider to resolve the issue.

     

    and below error I get when I update some WooCommerce Plugin like WooCommerce 360° Image, WooCommerce Additional Variation Images, WooCommerce Cart Add-Ons, WooCommerce Product Enquiry Form

    Automatic update overdue by 1 month. There may be a problem with WP-Cron.

     

    Kindly help to resolve these problems or it will become very troublesome with more WooCommerce updates.

    Also what is downside by using alternate Wp Cron?

    12 REPLIES 12
    JesseW
    Community Manager

    Hi @arunkumaran. Thanks for posting. It does appear that wp-cron has been disabled for Managed WordPress plans. However, I'm trying to find out more information on why that is and when customers can expect it to be working again. I'll update in that regard once I have more information. 

     

    As to the suggestion that you move to cPanel, I'm not sure why this would be offered, but the Guide you spoke with must have thought it made sense in your situation. I apologize for any confusion that may have caused. 

     

    In regard to advice on using an alternate to wp-cron, it may be helpful if you can explain what the alternate suggestion was. One of our pro WordPress users like @PL281 might be able to offer advice if you can provide more information. 

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give likes.

    @JesseW  Thank you for the additional information

    @arunkumaran For sites where I want to make sure Crons trigger without issue I use EasyCron.com - Personally I use their $24/year plan which allows me to configure cron triggers for multiple sites - most I have set to 5 minutes - but they can go as low as 1 minute

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Thank you JesseW. I understand, support team can give/advice on what is possible at the moment.

    Below is the alternative solution provided by GoDaddy tech support. I am not sure if I can access the wp-config.php from my GoDaddy account.

     

    Please add script under wp - config . php define as ( 'ALTERNATE_WP_CRON',TRUE ) or switch to cPanel hosting to have a true cron access.

     

    Also, please let me know why wp-cron has been disabled for Managed WordPress plans and what is the possibility to get this up and running. Many of the WooCommerce plugin provided as part of this package need wp-cron and should have been analyzed before giving the plugin's as part of the package to customers.

     

    Appreciate your  support.

     

    Regards,

    Arun.

    Like you I had to use the

    define('ALTERNATE_WP_CRON', true);

    entry in the wp-config.php. The tech support were of no real help, just confirmed my belief in that they are not aware of what some of their C&C team are up to.

     

    Many of the security plugins use WP-Cron to run some of their functions, so Go-Daddy are either intentionally or otherwise, reducing the security of their systems and many of our websites.

    Hi @JessieW/@Arunkumaran 

     

    I have this exact same issue and having spent a lot of hours over the last three days trying to get it resolved with the GoDaddy Support team. I was also advised to switch to CPanel, which as you've said seems to be a bit counter intuitive in order to get a product, provided by GoDaddy as part of my Managed Wordpress package, to work!

     

    In the end the support team added the 'ALTERNATE_WP_CRON',TRUE change to my site and though it did get AutomateWoo running it also created it's own issue in appending all my URLs with ?doing_wp_cron= and a whole string of numbers. Having done a little research on this I understand that this can screw up your SEO.  It's effectively creating duplicates of each post and we know search engines don't like large scale duplicate content...  

     

    So as I see it we still don't have a valid answer. We just need GoDaddy to enable wp-cron for managed wordpress sites so our updates work and AutomateWoo jobs can run... 

    JesseW
    Community Manager

    @vrhunter @arunkumaran @NotABinaryNum  - Thanks for the information. I'm looking into what's happened and relaying this information to our product team. Once I have more information, I'll follow up. I appreciate your patience in advance. 

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give likes.

    I have a client site on the Deluxe Managed WordPress plan.  Post scheduling stopped a few months back. I called support and was told "WP Crons are shut off on Managed WordPress for performance reasons. We do not know when the issue will be resolved.  Your options are to convert to a self-managed C Panel account or we will give you a free three-month extension. I asked if there was a formal statement posted from GoDaddy on this I could share with the client. Apparently not.  I checked other reports of this issue here and, apparently, this is supposed to work.  How do I get this issue resolved?

    JesseW
    Community Manager

    Hello All. Just wanted to give an update. Here are a few points:

     

    • wp-cron is not used on Managed WordPress plans. Instead, we use wp-cli to manage the things that wp-cron would normally handle. 
    • Cron activity is working for all but a few customers. 
    • For those it is working for, tasks that are typically handled by wp-cron may be delayed. We're working to improve this situation. 
    • For those it is not working for, we're looking to get a more permanent fix in place.

    Unfortunately, I do not have an ETA for when these issues will be fully addressed. I will update this thread if I have more information. We apologize for any inconvenience you're facing. 

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give likes.

    Dear JesseW,

    Thank you for the update. This has to be fixed your end ASAP.

    The main issue is Plugin Updates, most of WooCommerce and other plugins run WP Cron. So I try to call the file by adding wp-cron.php sometimes before update the plugin and update it. This is causing lot of issue with my site and the site down until it is fixed. I cannot trust this hosting and launch my site with so many Products.

    Kindly understand and provide a solution on this issue. This has to be fixed or don't sell the Managed WP Hosting with WooCommerce Plugin's. I am in a situation where I can't switch to different hosting or service provider.

     

    Regards,

    Arun.  

     

    Thanks for the feedback @arunkumaran. I will post updates as they are available. I understand this is a difficult situation and I apologize I don't have more information on when/how this gets fixed. 

     

    I do have some additional troubleshooting steps that you and others can try to identify issues that may be adding difficulty to the situation. 

     

    List Crons

     

    First, generate a list of the crons for your account. You can do this by accessing your account via SSH and using the following command:

     

    wp cron event list

     

     

     

    PHP Errors

     

    If the command above results in a PHP error (see examples below), you will need to correct the issue within your WordPress files in order for crons to run. Some steps troubleshoot PHP issues try might be:

    • Ensuring all plugins are updated
    • Disable all plugins and enable them 1 by 1 until you find the plugin breaking cron.
    • If the error calls out a specific file or error, directly fix the error.

     

    Parse error: syntax error, unexpected ':', expecting '{' in /var/www/wp-content/plugins/woocommerce/woocommerce.php on line 56

     

     

    "Wed Feb 24 20:28:34 2021 (1): Warning Interned string buffer overflow"

     

     

     

     5 minute timeout

     

    If the 'cron event list' command above completes takes longer than 5 minutes to run, the cron runner will be unable to execute your crons. You will need to try to modify your site to speed up the crons or consider moving to a different platform without these limits, like cPanel. 

     

    Run Crons

     

    If you do not have any of the issues listed above, you can try running this command:

     

    wp cron event run --due-now --all

     

     

    If the 'event run' command works correctly, the next time the cron runner tries to run, your crons should be executed. 

     

    Still need help? 

     

    If the above steps result in an error not listed or otherwise do not work, you will need to connect with our customer care team once more so your specific situation can be looked at closer. This is an evolving situation, and we appreciate your patience. 

     

    I hope this helps!

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give likes.

    I spent weeks a while back trying to diagnose this issue on two of our customer sites, one is a Managed WordPress and the other a Managed eCommerce WordPress.  Neither have WP-CRON running successfully due to GoDaddy having turned off the functionality, effectively GoDaddy are miss-selling the Managed WordPress products which is illegal under the Trade Descriptions Act but hey nothing will happen as it's a massive organisation with enough lawyers to tie-up trading standards for years.  

    We've had to work around by SSHing into the two sites on a daily basis to run the WP-CRON jobs.  We are actively pursuing moving off the GoDaddy services as a result.  

    Oh and to add insult to injury, Managed WordPress has been up and down like a yo-yo the last two days as well... 503 / 500, performance similar to that of a snail.

     

    Here's my original thread if it's any help - https://uk.godaddy.com/community/Managed-WordPress-Hosting/WP-CRON-HTTP-429-Error/td-p/174758

    Yep, been getting a few 500 internal server errors over the last few days, along with GoDaddy monitoring emails to say my site has been down - nowt to do with the website but the servers not being able to handle things.

    But then, I have also had a number of bot attacks searching for exploits to leverage. Good job I have decent plugin security alerting me to it.

     

    But the doing_cron displayed in the address field, for the ALTERNATE_WP_CRON workaround is not very professional for our sites.