cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Purchased a single domain registration, twice, the domain doesn't appear in the management area

Hello,

 

Firstly, I want to say thank you to anyone who can assist me with my issue because I am unable to phone in for help. Presently I'm sick and lost my voice so calling in wouldn't help. Also, I couldn't find a general support form to submit a trouble ticket so I ended up coming here, hope I'm in the right place.

 

Earlier today I had purchased a new .net registration (Order ID: 1170649819) and waited for quite a while but it had not appeared in the domain management area. I then checked to see if funds were withdrawn from my card, wondering if I made a mistake somewhere on my end, and funds hadn't been withdrawn. At this point I just assumed that it definitely was an error on my part and proceeded to re-purchase the same domain. I went through the same process again, made sure everything was on point and clicked checkout (Order ID: 1170752319).

 

After waiting for some time, I checked in the domain management area and again, the domain registration was not there. I couldn't search for it, nothing. I then checked my bank and found that the charge went through for both purchases, each of which was for the exact same domain registration. So now I've been charged twice but I still don't have the domain.

 

I'd like to know where the domain registration I purchased went to and how I can get a refund for one of the registration charges (seems odd having the form let me purchase it twice, there is no reason to pay for the same thing twice)?

 

I was reading through similar threads in here where other people having had issues similar to my own. I do apologize if I should have just piggy-backed on one of those threads instead of creating a new thread. I'm actually stumped by what happened because I can recall using Godaddy in the past years ago and never have I had any issues, not once.

 

I look forward to a reply from anyone willing to help with my conundrum.

 

Thanks,

 

Steve

4 REPLIES 4
Helper VI
Helper VI

Re: Purchased a single domain registration, twice, the domain doesn't appear in the management area

@attachment it seems pretty odd. Can you share the domain name?

 

By the way, have you tried chatting with support?

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: Purchased a single domain registration, twice, the domain doesn't appear in the management area

Hello,

 

Thank you for getting back to me as quickly as you have. Unfortunately due to the community forum being open to the public, I do not wish to share the domain registration here (both for privacy and concern if the domain has not been registered despite me paying for it twice). I wouldn't mind however sharing through a private message if it's available here? Also, as for the life of me, I cannot seem to find any link to a live chat. And when I come across some text that would look likely to be a place to have a hyperlink for the chat, there is none. I made sure to clean my cache, delete cookies and even attempted to view in a private window with no avail. I've included a few screenshots of what I'm presented with when I access various sections of the customer interface. I believe it's also been well over 12 hours since both purchases of the same domain. Could you provide a direct link to a live chat that I could access?

 

Below are the screen shots:

DEFAULT_VIEW_OF_DCC_008.png

 

 

DEFAULT_VIEW_OF_DCC_007.png

 

 

DEFAULT_VIEW_OF_DCC_006.png

 

 

DEFAULT_VIEW_OF_DCC_005.png

 

 

DEFAULT_VIEW_OF_DCC_004.png

 

 

DEFAULT_VIEW_OF_DCC_003.png

 

 

DEFAULT_VIEW_OF_DCC_002.png

 

 

DEFAULT_VIEW_OF_DCC_001.png

 

 And just below here are two examples where some sort of hyperlink or image map or button should be to access live chat however I do not see anything that would allow me to start the live chat.

 

Below I highlighted in red where I would assume there to be a hyperlink for live chat support:

 

text-where-a-link-to-chat-should-be-but-is-not-available.png

 

 The footer has an icon and text but is not clickable:

footer-no-chat-option-01.png

 

 Now I do apologize if I am looking in the wrong area for the live chat, it has been rather frustrating trying to navigate dozens of pages and turning up empty.

 

Alright, let me know what you think of all those pictures.

 

Thanks,

 

Steve

 

 

Re: Purchased a single domain registration, twice, the domain doesn't appear in the management area

Hi,

 

Okay so after an extensive checking against eight other registrars, they've all came back with the domain not having been registered. No change in whois and/or status. Some how I managed pay for a blank product through Godaddy. What's strange is that the only place of having any record of the domain is in the order history when you review both receipts. Beyond that, there is no other mention/instance/etc, as though something mid-process dropped the registration assuming it had to have taken place just after billing was processed.

 

I suppose I should just request the two refunds then? Or would you recommend that I wait and see?

 

Thanks,

 

Steve

Community Manager
Community Manager

Re: Purchased a single domain registration, twice, the domain doesn't appear in the management area

Hi @attachment. Welcome to GoDaddy Community! This is a strange issue. I highly recommend getting in touch with support so they can help you understand what's going on. You can reach them 24/7 at any of the numbers listed here. If you don't wish to call, you can reach out to our chat support team. They are available Monday - Friday, 5 am to 6 pm (MST) on the United States - English version of our Help page.

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.