cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution

All my emails go to Spam, new dedicated ip doesn't help ....

Hello folks.

I spoke to a few different folks from your team within the last few months about the fact that ALL mail from ALL my websites and domains on my account go directly to spam - my spam, my clients spam - always direct to spam.

It shows a yellow message above in spam that says;
Why is this message in Spam? We've found that lots of messages from n1nlhg103.shr.prod.ams1.secureserver.net are spam. 

 

So, despite me submitting a few blacklist removals and eventually seeming to have it off all blacklists ... nothing change. In the end, i lost patience and had to manually set up filters in my own email boxes just to RECEIVE my mail - but obviously i cannot do that for all customers of mine and it's so unprofessional to have to tell each of them to check their trash for our messages.

 

I just purchased a dedicated IP on the recommendation of two of you guys telling me that i'd no longer be punished sharing an IP with potential spammers ... everything has propagated and the new IP is active and guess what .... still the same! [the copy and paste above is the new message i'm receiving].

 

What is going on? Is it because google/gmail now block all from @secureserver ? 

 

This should very clearly work, but after numerous attempts, it's just like it was before i employed my filters, so i'm postive my customers will still be trawling through their trashes for our messages.

Can you help me with this? i really need this resolved and dedicated IP has done nothing other than cost me money.

 

thank you.

5 REPLIES 5
Solution

Re: All my emails go to Spam, new dedicated ip doesn't help ....

I appear to have resolved my own issue by using a simple wordpress plugin to completely remove secureserver from the picture entirely.

 

leaving this here for those of you that may need the help;

 

https://wpforms.com/how-to-securely-send-wordpress-emails-using-gmail-smtp/

Re: All my emails go to Spam, new dedicated ip doesn't help ....

Every email I sent to a gmail account ends up in spam, even if they have me in their contacts and have replied directly to my emails. I use the basic GoDaddy setup and I was told that there's something about how godaddy registers, or doesn't register their emails that Google doesn't like. Have you found a workaround for this?

Re: All my emails go to Spam, new dedicated ip doesn't help ....

Can you be more specific?

 

Are you sending from a website? [if so and on wordpress, use 'wp smtp' - it works so well].

If you're sending them directly and still going to spam ... that's an issue for godaddy!

Re: All my emails go to Spam, new dedicated ip doesn't help ....

I’m sending directly using these settings

 
 
There are comments about this all over the web and it’s said that it’s stated that it’s your server setup that’s causing this.
Highlighted
New

Re: All my emails go to Spam, new dedicated ip doesn't help ....

I just switched to the forced Exchange email GoDaddy system last week and now my emails - to people I have been communicating with for years via email - are going to spam!

 

Very frustrating and inhibiting my ability to run my business (I have to text these people to let them know they got an email from me).

 

Anyone else having this issue since the change over?

 

Help!