Skip to main content
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Emails going to spam?

I just recently signed up for GoDaddy's email on my domain (which I think is through Microsoft Exchange?), my email is hello @ selah and stone . com - but for some reason pretty much all the emails I receive on going to spam. Can I do anything to fix this? Maybe an spf record? If so what should the record be? 

 

Thanks, 

1 ACCEPTED SOLUTION
DAVENUG
Getting Started

OK, this is a simple solution.  Login to outlook on the web.  work your way to the MS Exchange admin center (little bars on the left), make sure you are in the EXCHANGE admin and NOT the GoDaddy Admin).  The admin center (url is outlook.office.365.com/ecb).  Once there click on "mail flow" on the left, click on rules and create a new rule (i called mine after the form that was going to spam)  - following the form syntax below for the rule (of course your actions will be a bit different, BUT what you want here is the Set the spam confidence level (SCL) to '-1'.  This SETS the EOP to bypass that message and NOT mark it as spam.  GoDaddy support staff does NOT know Exchange, or all the idiosyncrasies that Exchange offers.

 

Name of Rule: Res Bypass

Condition:  If the Message includes these words in the message subject or body “what ever that is for you”)

Do the Following: set the spam confidence level (SCL) to -1

Rule Mode: Enforce

Additional Properties: Sender Address Matches header

 

AnyWHO good luck to all looking for solution to this mess. There is also a way to turn off all spam filters here as well.  BE CAREFUL and if you don't understand WHAT I am talking about, Google MS Exchange EOP settings and READ about it FIRST!!!

 

View solution in original post

6 REPLIES 6
stumo
New

Having similar issue here. Inbound messages that say they are from my email address all end up in the Junk folder. I have no rules set up for Junk mail. I use the GoDaddy Quick Shopping Cart for my webstore and it sends me an email notification when I receive an order. My PayPal account does the same. Those emails that show they come from my email address always go to Junk. I've tried reporting them as not Junk and sent in the report but no help. Called tech support and they guy said that's just the way it is. I say bull as it used to work just fine.

TLH
Moderator
Moderator

Hi @selahandstone and @stumo ,

 

Welcome to the Community!

The first thing you'll both want to do is check the mail rules that may have been made inadvertently or need adjustment. This article (and the associated links) will help you get started.

 

 

 

TLH - GoDaddy | Community Moderator
Supporting you at x.co/247support

@TLH Yep, that's the first thing I checked. Had no rules set up at all. I did try adding a rule that all emails with my email address be moved to my Inbox. Did the same thing with using a Subject word and moved it to Inbox as well. Neither rule had any effect. I'm guessing emails that come from my own email address are being marked as Junk even before they get to Outlook 365. Had this once before several years ago and GoDaddy tech support finally found a way to correct on their end. Now techs don't want to bother and just say that's they way it is. No buying that line.

DAVENUG
Getting Started

OK, this is a simple solution.  Login to outlook on the web.  work your way to the MS Exchange admin center (little bars on the left), make sure you are in the EXCHANGE admin and NOT the GoDaddy Admin).  The admin center (url is outlook.office.365.com/ecb).  Once there click on "mail flow" on the left, click on rules and create a new rule (i called mine after the form that was going to spam)  - following the form syntax below for the rule (of course your actions will be a bit different, BUT what you want here is the Set the spam confidence level (SCL) to '-1'.  This SETS the EOP to bypass that message and NOT mark it as spam.  GoDaddy support staff does NOT know Exchange, or all the idiosyncrasies that Exchange offers.

 

Name of Rule: Res Bypass

Condition:  If the Message includes these words in the message subject or body “what ever that is for you”)

Do the Following: set the spam confidence level (SCL) to -1

Rule Mode: Enforce

Additional Properties: Sender Address Matches header

 

AnyWHO good luck to all looking for solution to this mess. There is also a way to turn off all spam filters here as well.  BE CAREFUL and if you don't understand WHAT I am talking about, Google MS Exchange EOP settings and READ about it FIRST!!!

 

View solution in original post

Took me a while to weed through all that and make it work but it worked. You're right, Go Daddy support does not know about Exchange. And your point of Exchange rules running first and local rules last helped me understand the whole deal. Thank you!

DAVENUG
Getting Started

Then your Outlook rules will work. EOP in Exchange is OVERRIDING your rules. Remember your email goes to the Exchange server FISRT - they apply their rules, then it goes to Outlook when you launch it.

 

MS figures it like this:

 

MS EOP and other Exchange Rules FIRST!!!

Outlook Rules Second or where ever they are in that list.  I always consider Local Rules as LAST in line after all the other Exchange rules.

 

D