cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution
shucky
Skilled

Error Sending SMTP Email - VPS Windows Plesk

Hello,

 

I have a Windows VPS and I am able to send SMTP emails using webmail (horde) however I can not send it using any client Outlook etc. I am pretty sure my settings are correct. I have followed the following steps

https://www.godaddy.com/help/adding-email-accounts-to-plesk-servers-160

http://download1.parallels.com/Plesk/PP12/12.0/Doc/en-US/online/plesk-administrator-guide/index.htm?...

 

However, if you follow the 2nd link the issue that people are facing are exactly the issue that I am having. I checked my windows firewall and port 25 is open for connections. I have a MX record for mail.mydomain.com.

 

Bottom line, it is working correctly when I use the webmail client that is installed on the server but does not work with an external client. Can somebody please help??

 

Thanks!

 

5 REPLIES
shucky
Skilled
Solution

Re: Error Sending SMTP Email - VPS Windows Plesk

Found the problem. No issue with the VPS or hosting - it was my local ISP who has been blocking port 25. Switched to 587 and it works. 

shucky
Skilled
Solution

Re: Error Sending SMTP Email - VPS Windows Plesk

Found the problem. No issue with the VPS or hosting - it was my local ISP who has been blocking port 25. Switched to 587 and it works. 

bryanchs
Novice

Re: Error Sending SMTP Email - VPS Windows Plesk

I am try to use SMTP port 587 but still having issue sending.

shucky
Skilled

Re: Error Sending SMTP Email - VPS Windows Plesk

Make sure you enable that port on your mail server. For example I am using the default mailEnable server. So go to mailEnable > servers > localhost > services and connectors > SMTP then right click and properties then go to inbound tab and then click on Settings... for Port Settings and in that check mark the submission port to allow listening to port 587. Hope that helps.

 

Thanks!

 

 

 

 

Bluesky1972
Novice

Re: Error Sending SMTP Email - VPS Windows Plesk

In my case I had to go in Plesk --> Mail --> What to do with mail for non-existent users * --> Select  "Forward to address" (instead of Reject) --> click on [Apply], and the emails were sent successfully.