cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution
New

Incoming emails going to junk

I noticed my email load was getting less and less, so logged on directly to my GoDaddy webmail and found 16 pages in my junk folder from the last 3 weeks.  Some of them were items I had sent myself from my own go daddy email!  I've been on chat with 2 different support people and it's still happening.  The weird thing is that it's not all of them, but definitely like 90%.  Help!  I don't have time to log on manually to monitor.  I use an iPhone and Mac, but the issue seems to be GoDaddy so I can't imagine that matters. 

6 REPLIES 6
Moderator
Moderator

Re: Incoming emails going to junk

Hi @VickiV,

 

If there are certain domains that you want to ensure you get emails from, you may want to log in directly to the Workspace Email, and add those to your Allowed List.  You may also want to review info that's in your email signature, as sometimes links that could be considered spammy may end up triggering filters.

 

If you keep getting flagged as spam, you may want to contact Customer Care to see if there are any other steps they could offer as well.

 

 

ML - GoDaddy | Community Moderator
24/7 support available at x.co/24-7support
New
Solution

Re: Incoming emails going to junk

After 3 failed attempts with customer service basically I was told that any email having a link or phone number in their signature can potentially go to the junk or spam folder.  REALLY?  That's every email I receive.  Also, it is my incoming emails going to spam but they kept talking about MY outgoing emails being received as spam. That is not the issue. Anyway, I have been logging on to my webmail 5-10 times a day to manually remove all of my email from SPAM.  What an amazing pain.  Guess what I just found under settings??  "Enable" spam filtering.  That is all I needed to know!  How could this not be an immediate suggestion by support?  They literally told me that there was nothing they could do to help me.  I'm absolutely shocked.  

Re: Incoming emails going to junk

@VickiV

Where did you find the option to where you were able to enable spam filtering? I am unable to locate that. Thank you

Re: Incoming emails going to junk

sugashaa-

On a line in the upper right-hand frame of your GoDaddy WORKSPACE page

(the tabs for email and calendar are on the LEFT side of the same line)

you will see that you are either in CLASSIC VIEW or in UPDATED VIEW.

Here are instructions for each.

****If you are in CLASSIC view -

on the LEFT click on the EMAIL  tab

then, on the RIGHT (just BELOW the words CLASSIC VIEW, find the little "gear" shaped icon--

(on my screen it's yellowish-orange)  CLICK on it

at the BOTTOM of the pull-down menu CLICK on "More Settings"

on the Settings page (just below the large word "SETTINGS" you will see a line of tabs that don't look like tabs, they just look like words

one of those words is SPAM... CLICK on it and you will find the controls for Spam and Junk filtering

******If you are in UPDATED view-

on the LEFT click on the EMAIL  tab

then, on a line just BELOW that Email tab, find the an option for SETTINGS... NOT Tools but SETTINGS

CLICK on it

On the pull-down menu CLICK "Spam Settings," and find the controls for Spam and Junk filtering

Good luck.

Re: Incoming emails going to junk

On a line in the upper right-hand frame of your GoDaddy WORKSPACE page

(the tabs for email and calendar are on the LEFT side of the same line)

you will see that you are either in CLASSIC VIEW or in UPDATED VIEW.

Here are instructions for each.

****If you are in CLASSIC view -

on the LEFT click on the EMAIL  tab

then, on the RIGHT (just BELOW the words CLASSIC VIEW, find the little "gear" shaped icon--

(on my screen it's yellowish-orange)  CLICK on it

at the BOTTOM of the pull-down menu CLICK on "More Settings"

on the Settings page (just below the large word "SETTINGS" you will see a line of tabs that don't look like tabs, they just look like words

one of those words is SPAM... CLICK on it and you will find the controls for Spam and Junk filtering

******If you are in UPDATED view-

on the LEFT click on the EMAIL  tab

then, on a line just BELOW that Email tab, find the an option for SETTINGS... NOT Tools but SETTINGS

CLICK on it

On the pull-down menu CLICK "Spam Settings," and find the controls for Spam and Junk filtering

Good luck.

New

Re: Incoming emails going to junk

Open and Login to your account on Outlook 365

 On the left:

 -Open Settings

       -Open Accounts

           -Open Block or Allow

               -Select option "Don't Move Email to my Junk Email Folder"

 

This worked for me, I hope this helps!