cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Laravel SMTP - Sendgrid not working

I am using Laravel SMTP basic auth with Sendgrid and this worked when the website is hosted locally but then it does not work when the website is hosted on GoDaddy. Anyone experienced similar issues?

5 REPLIES 5
Helper VI Helper VI
Helper VI
Solution

Re: Laravel SMTP - Sendgrid not working

SMTP protocol doesn't always work with GoDaddy... I think it's some PORT issue if I remember correctly.

 

Try using Sendgrid's rest API instead... Rest APIs are usually accessed via HTTP/S protocol which are allowed 99% of the time.

 

Try this php package: https://packagist.org/packages/sendgrid/php-http-client

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com
Helper VI Helper VI
Helper VI

Re: Laravel SMTP - Sendgrid not working

@iottechnical 

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com
Highlighted

Re: Laravel SMTP - Sendgrid not working

Resorted to using the API after a lot of time wasted trying to get the SMTP to work. As far as I know you need a dedicated server for the SMTP to work on GoDaddy.

Re: Laravel SMTP - Sendgrid not working

Hi!  I don't understand all the techno-speak, but I get a number of emails where, since June, all the links go to a sendgrid location (e.g. https://u1584542.ct.sendgrid.net/mps2/c/AgE/ni0YAA/t.2uo/4ymAORbxQBSbuw4WbDQLIQ/h1/Nejq3qQQ6Jn1R8HM5...) which is invalid.  It was not a problem before June, and links in emails from other organizations work fine.  I've tried contacting these organizations, but they say nothing is wrong.  So, did something recently change in godaddy?  Is there something relatively simple that I can do to regain full functionality of email links?  I do not understand your answers below, or if it even applies to my situation.  Is there some setting I can change?  And if so, to what?

Thanks!

Diane E Harrison
Helper VI Helper VI
Helper VI

Re: Laravel SMTP - Sendgrid not working

@dianeliz 

I think this is the wrong thread for you.  Please create a new topic so that other users can find your question easier thus higher chance of someone being able to help you.

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com