cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

cPanel and Office 365 Autodiscover

We have an issue with Outlook 2016 trying to Auto discover to Office 365 (not GoDaddy Version), the DNS is all correct and with GoDaddy/Microsoft but the Auto discover is trying to connect to cPanel version which is not right.

 

Is there anyway of disabling or removing AutoDiscover from cPanel.

 

3 ACCEPTED SOLUTIONS

Hey @C5support,

 

Did you check your cPanel MX settings to be sure they're set to 'Remote' instead of 'Local'? The autodiscover.xml file you're referencing would only be referred to locally if you haven't specified that your email should be directed to another provider via these settings. 

 

Let us know if that helps.

CG - GoDaddy | Community Moderator
24/7 support available at x.co/247support

View solution in original post

For anyone who hasn't found it yet, it is indeed found in the GoDaddy control panel. From your My Products page click Manage next to your domain to go to the Domain Settings page.  Once there, click Manage Hosting. Click Manage again (seriously!) which will take you to a page with lots of icons. Scroll down to the email section and click MX Entry.  The setting is there - select Remote Mail Exchanger, then click Change. You might also update the MX record at the bottom - ours didn't match the one on our DNS records page.

View solution in original post

I have resolved the issue by setting the MX Entry to Remote. It took at least 48 HOURS for changes to take effect

View solution in original post

35 REPLIES 35
Employee

Hi @Stephen1

 

Thank you for your post. Sound like you may have an extra CNAME dns record causing the conflict. Or your network is caching the old CNAME autodiscover record. Please take a moment to review your DNS records and look for a CNAME:

Name: autodiscover

Points to: @

 

If you find the above record it may be causing the conflict. If you would like assistance reviewing your DNS records please feel free to contact our 24/7 customer support team and they will be happy to go over and review the DNS settings for your domain if you host your DNS with GoDaddy.

 

Best wishes!

-Techfly 

We have the exact same problem. It's a known issue in cPanel apparently. It's because of the order in which Autodiscover is done by the client before it even checks for a valid CNAME. This is IMPORTANT!

 

This can be confirmed via testconnectivity.microsoft.com when validating autodiscover.

 

In this case, the client finds (using example.com as an example for sake of discussion) https://example.com:443/Autodiscover/Autodiscover.xml

 

This then redirects with the following information to the client to p3nlwpproxy002.prod.phx3.secureserver.net which is **NOT** Office365!!!

 

We need a way to disable to autodiscover.xml file on your server so it's not being referred by the client.

Hey @C5support,

 

Did you check your cPanel MX settings to be sure they're set to 'Remote' instead of 'Local'? The autodiscover.xml file you're referencing would only be referred to locally if you haven't specified that your email should be directed to another provider via these settings. 

 

Let us know if that helps.

CG - GoDaddy | Community Moderator
24/7 support available at x.co/247support

View solution in original post

This was the perfect fix for us.  5 hours on the phone with Godaddy's support.  Called a bunch of times hoping to get the right person in the various departments and still no help.  Thanks to a more thorough google search, this thread came up.  Thanks. 

Same issue, many hours on the phone with GoDaddy, our wordpress developer and microsoft. NO RESULTS - I am so pissed I could spit!

We are experiencing this same issue right now with two domains.  I have made the MX setting changes but so far this has not helped.  I think the setting changed help with one item, but now i am getting a message that states "An encrypted connection to your mail server is not available".  This has something to do with GoDaddy because i management multiple office 365 customers and only the ones that use GoDaddy for domain management have this issue.  

I just fixed one client using this procedure but still having issues with another domain.  I will keep you posted.

https://www.godaddy.com/help/outlook-pc-clear-the-windows-credential-manager-9197

 

Thanks, this was same issue for me. MS 365 support wanted to go through local pc registry hacks for autodiscover when it was obviously a DNS MX problem. 

 

Fixed!

^--  This worked.

 

Nothing has changed in our setup, but users that were previously working ok in Outlook (since going live with GoDaddy) suddenly were not configurable as new users to a PC.  The troubleshooting steps all seemed to be focused on autodiscover.  Microsoft had me add registry tweaks per user per pc to get it working, but that's a poor long term solution.  After a lot of searching found this thread, checked the MX setting, and sure enough it was set to local.  Changed to remote and now all is working again.  Thank you!

Glad it worked for you . Thanks for sharing. My MX records is set to address specified by Office365 Admin Group.

 

I still have no resolution....

This did the trick. Setting cPanel hosted MX Entry under email routing to 'Remote' instead of 'Local' worked like a charm. Thanks CG for your help...

GREAT RESPECT to whomever discovered this. I've been on the phone with GoDaddy, Microsoft, our WordPress developer, etc. GoDaddy was absolutely useless and blamed my DNS settings. Microsoft's only fix was the registry hack and our WP guy basically said it was my issue, not his. You have saved my ass. 

This worked like a charm! I just logged into my cPanel and went to the email section, selected the "Remote Server" option and hit save. Instantly my outlook 2016 worked.

Setting the MX entry to Remote instead of Local did not fix the issue for me. Is it because we have SSL turned on on our website? 

SSL shouldn't make any difference to DNS. Do an nslookup in the CMD line "nslookup autodiscover.YOURDOMAIN.com" and make sure the entry resolves to microsoft (for o365). After you disable email on cpanel you still have to create an autodiscover entry in DNS for it to resolve correctly.

 

 

Example:

Non-authoritative answer:
Name:    autod.ms-acdc.office.com
Addresses:  2603:1036:804:a::8
          2603:1036:804:22::8
          2603:1036:804:1::8
          2603:1036:804:c::8
          40.97.120.232
          40.97.120.184
          40.97.120.136
          40.97.120.40
Aliases:  autodiscover.yourdomain.com
          autodiscover.outlook.com
          autod.ha.office365.com

my DNS settings were verified in Office 365 so no issues there

 

The issue is Outlook looks at the root domain first - i.e. https://domain.com/autodiscover/autodiscover.xml

 

which points to a webpage hosted on cpanel on the backend  which indicates "

autodiscovery must be provided a valid email address 

 Outlook attempts to contact topleveldomain.com/autodiscover.xml as it’s first port of call, before eventually getting to autodiscover.topleveldomain.com/autodiscover.xml. If it instead tried autodiscover.topleveldomain.com/autodiscover.xml first, the problem would disappear immediately.

The recommended fix is to log into cPanel and set the MX entry to “Remote” instead of “Local”. Unfortunately this did not fix the issue

It seems that it only affects HTTP, but not HTTPS requests?

I have resolved the issue by setting the MX Entry to Remote. It took at least 48 HOURS for changes to take effect

View solution in original post

It worked and saved my day..Thank you !!!