cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

problems with smtp and godaddy hosting

More than a month I have problems with the SMTP service with GoDaddy and I have no solution by "support", i have talking by chat and by phone, without any kind of support. being honest, I would never recommend this hosting, I've lost a lot of time and money with them

1) it is already known that godaddy blocks the connection to gmail (smtp)
2) cpanel email by smtp do not work (We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.)
3) smtp with workflow does not work (connection refused)

a hosting without SMTP, is useless, and the support leaves a lot to be desired.

10 REPLIES 10

¿What is the correct way to configure SMTP with Godaddy?

Good Day,

 

I was having an error on my phpmailer smtp configuration

1) Configuration

$mail->Host       = "relay-hosting.secureserver.net";
$mail->Port       = 25;                   
$mail->SMTPDebug  = 0;
$mail->SMTPSecure = "none";                 
$mail->SMTPAuth   = false;
$mail->Username   = "";
$mail->Password   = "";

error Sat, 06 Jan 2018 14:44:46 -0700 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.

 

2) With CPANEL EMAIL

$mail->IsSMTP();
    $mail->SMTPSecure = 'false';                            // Enable TLS encryption, `ssl` also accepted
    $mail->SMTPAuth = false;                               // Enable SMTP authentication

$mail->Host = 'smtpout.secureserver.net';
$mail->Port = 80;
$mail->Username ='XXXXXX@XXXXXX.com';
$mail->Password = 'XXXXXXX'; //Su password

3) With Localhost

$mail->IsSMTP();$mail->Host = 'localhost';$mail->Port = 25;$mail->SMTPAuth = false;
/*$mail->Username = "usuario@hosting.com";
$mail->Password = "*******"; //Password*/

Any work

Employee
Employee

Re: ¿What is the correct way to configure SMTP with Godaddy?

It depends on your hosting type. Your first configuration is fine with any hosting type other than cPanel. With cPanel the server should be localhost, but everything else the same, no SSL or login.

 

The server names are outlined here: https://www.godaddy.com/help/what-is-the-name-of-my-hosting-accounts-relay-server-953

Re: ¿What is the correct way to configure SMTP with Godaddy?

First of all, godaddy or any other type of smtp (gmail, sendgrid, hotmail) blocks it

1) the first  and second configuration with localhost , this error appears

Mon, 08 Jan 2018 08:28:41 -0700 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.

2) and with workflow connection refused

Super User II
Super User II

Re: problems with smtp and godaddy hosting


@MarkWebber wrote:

More than a month I have problems with the SMTP service with GoDaddy and I have no solution by "support", i have talking by chat and by phone, without any kind of support. being honest, I would never recommend this hosting, I've lost a lot of time and money with them

1) it is already known that godaddy blocks the connection to gmail (smtp)
2) cpanel email by smtp do not work (We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.)
3) smtp with workflow does not work (connection refused)

a hosting without SMTP, is useless, and the support leaves a lot to be desired.


@MarkWebber Are you referring to pulling your Godaddy emails through your hosting account into something like gmail or outlook? It's very possible, I've been doing it for years. 

 

https://www.godaddy.com/help/set-up-your-email-address-with-pop-4715

---

Re: problems with smtp and godaddy hosting

I mean, configure SMTP with php

 

Highlighted
Employee
Employee
Solution

Re: problems with smtp and godaddy hosting

PHP mail() is already configured, you don't need to specify SMTP info.

 

<?php
   $to = “your@emailaddress.here“; // <– replace with your address here
   $subject = “Test mail”;
   $message = “Hello! This is a simple test email message.”;
   $from = “sender@emailaddress.here“;
   $headers = “From:” . $from;
   mail($to,$subject,$message,$headers);
   echo “Mail Sent.”;
?>

That's a sample of code that works without having to fuss with it. 

 

If you insist on using SMTP, this should work, the system doesn't require auth:

 

$mail->isSMTP();
$mail->Host = 'localhost';
$mail->Port = 25; 

 

New

Re: ¿What is the correct way to configure SMTP with Godaddy?

Hi there.  Did this work for you?  If so, would you mind explaining a little further?  Thanks.

Re: ¿What is the correct way to configure SMTP with Godaddy?

If you are still having trouble and are using cPanel Linux shared hosting I have just found a solution. After several days, and 5 support chats later, all conveying contradictory information, this worked for me:

If you are using a third party email host: (which I suggest you should, as some are even free)

Firstly make sure your MX records (found in cPanel DNS records) are changed to their mail servers. For example if you use somebody like Zoho, it would be: zmverify.zoho.com. Ideally you will have a backup server or two to add as well, and then you can set priority, say 0 for the first server, 10 for backup 1, and 20 for backup 3. The lower the number, the higher the priority.

Next:  set SMTPDebug to 3, to get the maximum error information if your form fails.

Next, get onto the live chat, or support and ask them for your specific server host name. No not the relay-hosting server as that does not work. Nor localhost if you are sending the emails via a third party SMTP host. 

        $mail->isSMTP();
        $mail->SMTPDebug = 0; // for production use, but set to 3 for debugging
        $mail->Host = 'n3plcpnl0012.prod.ams3.secureserver.net'; //my specific shared server
        $mail->Port = 25; 
        $mail->SMTPAuth = false; 
        $mail->SMTPSecure = ' '; 
        $mail->Username = ' '; 
        $mail->Password = ' '; 

        $mail->SMTPAutoTLS = false; // Prevents opportunistic TLS encryption

Note that Username, password and SMTPSecure are included but are empty strings, do not set SMTPSecure to the boolean false, as this won't work either.


The thing that got it working for me is setting SMTPAutoTLS to false (final line of code), as the shared servers do not have a valid SSL/TLS certificate and so are rejected by the mail server. Without this line you might recieve an error of:

Warning: stream_socket_enable_crypto(): SSL operation failed with code 1

If you recieve any other errors, check the PHPMailer troubleshooting guide and work your way through it

Disclaimer: Incase you haven't figure this out already this is not secure. Any information sent via your email form will not be encrypted, and so can be intercepted by anybody. It seems that GoDaddy don't want to offer secure SMTP without upgrading to their email plans, but even then I would be skeptical that they would work properly either.

Best of luck!


Employee
Employee

Re: ¿What is the correct way to configure SMTP with Godaddy?

You can use localhost instead of your servername https321. But most of those instructions are helpful but you seem to be treating email generated by the website in one of our hosting accounts the same as other types of email. But they're not. Also the MX records put in cPanel do nothing in my experience. It's the local / remote routing setting that makes a difference.

 

With cPanel's hosting relays, you are literally connecting to a mail service on the same machine your website is hosted on. That connection isn't going over a network, so saying it can be intercepted by anybody is an overstatement.

 

For mail generated by a website running in shared hosting, you're limited to using the mail services built into cPanel so all mail flows through GoDaddy's relays. Form mail can't go out any other way unless it's an API service like sendgrid.com, and that's on purpose. GoDaddy has to have control of the mail generated by hosting accounts, and the ability to suspend hacked sites and other malicious uses from sending mail.

Re: problems with smtp and godaddy hosting

Hi,

This worked for me:

 

Select your hosting and go to the c-panel admin board.

Search for MXEntry, under Email

In email routing select Local Mail Exchanger

 

After a week and like 3 calls to support, I figured that out without their help. They had no idea what was going on. Pretty annoying.

 

Hope this helps!