cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution
kbell
Novice

Need to update Classic Linux Hosting to PHP 5.4

The Settings->Programming Languages window for my account shows ONLY  PHP 5.3 even though the info box under Did You Know? says that 5.4 is available. Is there a way to get it?

 

I need PHP 5.4 for current releases of WordPress plugins.

 

 

7 REPLIES
Highlighted
kbell
Novice
Solution

Re: Need to update Classic Linux Hosting to PHP 5.4

Told by Chat support that PHP 5.4 is not supported for 2GH classic linux users. Apparent plan is to drive out Classic hosting users by allowing bitrot to set in.

chonkat
Novice

Re: Need to update Classic Linux Hosting to PHP 5.4

Seriously?  If I have Deluxe Classic Hosting Linux I can't update past php 5.3?

Under Programming Languages it says "You get PHP for free. PHP 5.3 is our default version. PHP version 5.4 is available and meets our stability and security requirements. Version 5.2 isn’t actively supported." but it does not show as an option.

 

 

cole
Novice

Re: Need to update Classic Linux Hosting to PHP 5.4

Just rang support about this, they said i need to move to a newer server. Got me to turn on SSH which started the migration and when it is finished then on that server 5.4 should be available. Waiting for the migrate...

elscreative
Novice

Re: Need to update Classic Linux Hosting to PHP 5.4

Hi Cole,

 

I'm wondering how the server migration went, and if that solved the update to PHP 5.4. I'm having the same issue with my Classic Linux Hosting, stuck at PHP5.3.

Barinvon
Novice

Re: Need to update Classic Linux Hosting to PHP 5.4

Did they put you into a new plan ... $25 per month?
bhapca
Novice

Re: Need to update Classic Linux Hosting to PHP 5.4

I tried the enabling of SSH and the ensuing server migration. It solved nothing. I'm still stuck on PHP 5.2, with no option to upgrade. 

David_B
Novice

Re: Need to update Classic Linux Hosting to PHP 5.4

Your post was helpful.  I turned on SSH and my hosting now says that my pages are being migrated.  Why no one mentioned my PHP being unsupported and how to fix it any of times they called to upsell me on things I don't know, but maybe in a supported version of PHP, but hopefully I will be able to increase the memory limit and keep my site from crashing.  Thanks!