cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted
New

Cannot extract zipped file in Plesk hosting

I got the following error message when tried to unzip a file.

 

I chatted with one support yesterday and was told the tech team was working on this issue. But apparently the issue hasn't been fixed.

 

I subsequently searched the community and found some posts said unzip is not longer supported. Is it true? If so, how can I upload a collection of files?

 

I have also tried FTP. After log-on, listing directory never comes back. So the FTP option is not good either.

 

So, how can I update my website?

 

(BTW, now the online chat appears always "busy")

 

--- error message ------------------------------------------------------

Unable to extract ...: 'C:\Windows\system32\cmd.exe' is not recognized as an internal or external command, operable program or batch file. at Plesk impersonation(PipeServer::ServerThread::impersonateRunAs line 726) at Unable to unpack archive G:\PleskVhosts.\......zip(UnpackArchive::onRunAsUser line 2709)

1 REPLY 1
Super User II
Super User II
Solution

Re: Cannot extract zipped file in Plesk hosting

Hello 

It seems that 7-Zip, which is used by Plesk to work with archives, is not properly installed on the server.

To resolve it, download and (re)install 7-Zip and make sure that installation directory, for example, C:\Program Files (x86)\7-Zip has all permissions for user psacln.

Or replace 7.exe and 7z.dll in %plesk_bin% folder with ones taken 7-zip installation directory.

OR

There may be a technical issue.  You can unzip any .zip files on your hosting account.

  1. Login into your Plesk shared hosting account.
  2. Next to the hosting account you want to use, click Manage.
  3. Click Plesk Admin.
  4. Click the File tab.
  5. Select the file you want to unzip, click More, and then click Extract Files.
  6. Click OK.

After unzipping them, you might want to move the files.

 

You can also read

https://pk.godaddy.com/help/unzip-files-in-cpanel-hosting-16312

https://pk.godaddy.com/help/unzip-files-8396

 

Zulfiqar Anees | GoDaddy Pro | Founder/CEO at FastTech Media, TechMag, and ZulWeb.