Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Joomla 3 on Windows Plesk Hosting



Just joined GoDaddy with an established Joomla web site and to be quite honest I am a bit shocked at the problems I am encountering.


I have searched many sites for information on how to get a Joomla site working on GoDaddy and I am going around in circles, hopefully someone here can point me in the right direction.


Basically I am getting Internal Error 500 EVERYWHERE in the admin screens. The PHP temp folder is set to C:\Windows\Temp, which is unwriteable, and I am not having any luck changing it. My Configuration.php permissions have been changed to FULL control but it is still being shown as unwriteable. No one at GoDaddy can help, all in all I am hitting issues I have not encountered before and I have been running the web site many years now.


Does anyone have any words of wisdom or answer for me? If not I can see my time at GoDaddy being very short! Thanks.


BTW, I do need a Windows server, changing to Linux is not an option for me.

Community Manager

Hi @ChrisDSlack. Welcome to GoDaddy Community! 


My guess would be that there could be that you need to update the permissions of the directory you're trying to write to. On a Plesk account, you can do that with the instructions in this article. Hope that helps. If not, hopefully another community member will have insight into your problem.


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give likes.

Hi @JesseW,


Tried that, and it didn't work.  All my folders now have RWCD permissions, for all four user groups available.


Have noticed that the PHP 'Open basedir' setting is incorrectly set to ...



G:/PleskVhosts//<account domain name>.com\;C:\Windows\Temp\


Joomla does not have access rights to these folders, in fact the first one looks totally wrong having two '//' in the address. I have tried to override this value using the .user.ini file and this just does not work, even though I have recycled the application pool.


It seems that GoDaddy do not configure the Windows account PHP settings correctly and also the .user.ini functionality. Not very impressed so far unfortunately.

Hi @ChrisDSlack


Did you find a final solution?



No, unfortunately not.


Settings the folder/file permissions using the Plesk control panel did not work. GoDaddy really couldn't care less, and didn't understand what I was talking about. Not very acceptable service from a large hosting company, they don't seem to want to improve their support and prefer to drive people over to Linux hosting away from Windows hosting as a solution.

try to change the path of your temp n log file to '../temp'
and for lof '../log'

We had the identical problem. Had one nice and helpful CSR's and two very rude fellows. I had to open up full access to ALL directories/folders/files in order to access one directory. They tell me that it's not their problem that I can't manage my file permissions properly.


I strongly recommend anyone using their Plesk server hosting to abandon ship!