Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Facing issues installing Multi-Domain SAN SSL Certificate on IIS-10

We have purchased a "Standard UCC SSL Up to 20" recently.

After downloading the certificate files (9375d5a36efeb537.crt, 9375d5a36efeb537.pem, gd-g2_iis_intermediates.p7b) we found .pfx file is not available for installing the certificates on IIS-10.


We have tried to generate this  by using openssl; but facing an error as "Expecting: ANY PRIVATE KEY"


OpenSSL> pkcs12 -inkey C:\SSC\connect\9375d5a36efeb537.pem -in C:\SSC\connect\9375d5a36efeb537.crt -export -out C:\SSC\connect\9375d5a36efeb537.pfx


unable to load private key
22508:error:0909006C:PEM routines:get_name:no start line:crypto\pem\pem_lib.c:745:Expecting: ANY PRIVATE KEY error in pkcs12


we have tried using the private keys from server as well instead of .pem, however error is same.

Looking for help/suggestion to overcome this issue. Thanks in advance.


Re: Facing issues installing Multi-Domain SAN SSL Certificate on IIS-10

Just an update to my reported issue-


I'm able to find a fix to this as below:
1. Open the server generated Private Key file in notepad++ and changed its encoding format from UTF-8-BOM to UTF-8 and save the file again.
2. Rename the file to "generated-private.key"
3. Run below command in openssl.
     openssl pkcs12 -export -in 123456.crt -inkey generated-private.key -out 123456.pfx
4. Generated “123456.pfx” file without any issue.


I have successfully installed and configured my .pfx on IIS-10.