cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New

SSL Added & Can't Log Into WP-Admin

Hello,

I added Cloudflare SSL to my site (updated the nameservers to cloudflare prior). This was a needed to step to getting approved. After getting approved, I went over to Wordpress > Settings > General > and updated the following to include HTTPS.

- Site Address (URL)

- WordPress Address (URL)

Upon doing this, I'm no longer able to access .com/wp-admin or log in to continue my work at all.

The error that shows up on Firefox is: The page isn’t redirecting properly. Any way to roll back/fix this?

Thank you.

4 REPLIES 4
Advocate VII

Hi @YY_PDF,

 

Give it about an hour to properly propagate.  Sometimes when switching from http to https a refresh of DNS cache has to cycle throuugh for the update to be fully recognized. 

 

Also,  have you tried logging out of your GD, clearing your cache, and then logging back in?  This has worked for me several times. 

 

Hope this helps,

James

 

 

Not Just Pretty Sites, Pretty Doggone Smart Sites

Thank you @JMPepper, this has been going on for quite a few weeks now. I was able to get back by going to CPanel > PhpMyadmin > wp_options and changed the URL back to HTTP. Also, paused cloudflare, turned off cloudflare's Automatic HTTPS Rewrites and changed the nameservers back to the default ones.

 

Alas, some pages still force now and I get the "unsecure" connection unless i manually edit the URL in the URL bar. When I'm logged into the WP backend and want to visit the  site (top left corner of the top WP menu)  it's still set on HTTPS.

@YY_PDF When using Cloudflare and enabling SSL on Cloudflare side, any domain that goes through cloudflare will have a secure connection from there computer to Cloudflare. The connection from your website and Cloudflare is not secured and will require an SSL Cert to enable a Secure connection between your site and Cloudflare. If you enabled SSL on on your site without installing an SSL Cert on your server then you will not be able to access your site if forcing HTTPS. 

 

For your wordpress site you will need to make sure all URLS start with http:// and not https:// you may need to use PHPMyAdmin to search your database for any links with https:// and change back to http:// 

Make sure you do not enable Force SSL for your site. Once this is done and you verify your site is working you can switch back to Cloudflare (Changing name servers, enabling Cloudflare and SSL)

If you decide to enable SSL On your server then you will need to purchase and install an SSL Cert on your webhost before enabling SSL in Wordpress.

New


@YY_PDF wrote:

Hello,

I added Cloudflare SSL to my site (updated the nameservers to cloudflare prior). This was a needed to step to getting approved. After getting approved, I went over to Wordpress > Settings > General > and updated the following to include HTTPS.

- Site Address (


@YY_PDF wrote:

Hello,

I added Cloudflare SSL to my site (updated the nameservers to cloudflare prior). This was a needed to step to getting approved. After getting approved, I went over to Wordpress > Settings > General > and updated the following to include HTTPS.

- Site Address (URL)

- WordPress Address (URL)

Upon doing this, I'm no longer able to access .com/wp-admin or log in to continue my work at all.

The error that shows up on Firefox is: The page isn’t redirecting properly. Any way to roll back/fix this?

Thank you.



@YY_PDF wrote:

Hello,

I added Cloudflare SSL to my site (updated the nameservers to cloudflare prior). This was a needed to step to getting approved. After getting approved, I went over to Wordpress > Settings > General > and updated the following to include HTTPS.

- Site Address (URL)

- WordPress Address (URL)

Upon doing this, I'm no longer able to access .com/wp-admin or log in to continue my work at all.

The error that shows up on Firefox is: The page isn’t redirecting properly. Any way to roll back/fix this?

Thank you.




)

- WordPress Address (URL)

Upon doing this, I'm no longer able to access .com/wp-admin or log in to continue my work at all.

The error that shows up on Firefox is: The page isn’t redirecting properly. Any way to roll back/fix this?

Thank you.