Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SSL Not working with older Classic Hosting account

For weeks I have tried to figure this out on my own. My main domain seems to work fine. I'm on an older Classic Web Hosting account, NOT Cpanel. 


I have other domains that I host under that kalsonmedia account.  I have those sites in their respective folders, however they break as soon as I put the htaccess file in the directory for the domain name. I have over 200 of these SSL's to install on 8 different classic plans, and have had no luck with tech support. They don't seem to understand how to solve it. Using their suggested code below breaks any site I put it on. Our sites are not wordpress, just straight HTML coded sites. Thanks a million times for anyone who can figure this out for me. I've purchased an SSL for each site on that server, so time is of the essence. This has cost me a small fortune not to be able to get it resolved in a timely manner. I'm beyond frustrated with Godaddy. Any sites I host in Cpanel have worked out fine. 


RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteCond %{HTTP_HOST} ^(www\.)?coolexample\.com
RewriteRule ^(.*)$$1 [R,L]