Showing results for 
Show  only  | Search instead for 
Did you mean: 

Browser showing IP address not Domain in WordPress

I got a domain, and it is forwarding to my newly created wordpress.


Now, when I enter the domain I bought, it forwards me correctly to my wordpress website. But the problem is that browser displays the IP address of the website instead of the domain name. I am sure this is a very simple fix but I don't know how. How can I fix that?

Helper III

This should be an easy fix.  First, log in to your WordPress Admin console, then click settings on the left.  There are two fields you probably need to change:


WordPress Address (URL)

Site Address (URL)


If either of those fields has your IP Address instead of your Domain Name, it will redirect people to your IP address instead.

The options are greyed out. I tried to change both of them from the wp-config.php. When I do that, I am unable to log in to wp as the login page is not responsive. The rest of the website works fine. Is there a fix for that?