Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't use "add media" button or visual/text tabs in editor on Chrome

This morning my site was down for a few hours, which is distressing enough but now something strange is happening. I tried to add a post to which I had uploaded images, but I can't access the "add media" button. The drop down boxes work, I can navigate around the editor no issue, but this won't work. Then I try clicking on the visual and texts tabs - nothing. Doesn't respond. I text with GoDaddy yet again today and I'm told to clear my cache. I had already done that this morning before I knew it was a GoDaddy issue and I not only cleared my Chrome cache, but I also flushed the website cache. Still nothing. 


I've opened up Safari, which I hate doing and was able to add media to the post without any issues. I returned to Chrome and still nothing. But now I notice that the editor doesn't allow me to scroll within the window. Instead it has become one gigantic page. I really need some help and can't bear the thought of calling again if this is an easy issue to resolve. Every time I call, "sales & support" attempts to help me and without fail, they need to transfer me. Nothing like having to explain everything twice. So please --- if you have any ideas and think you can help me, please let me know. 


UPDATE: So it appears to be a Chrome issue that is outside of the scope of GoDaddy support. If all I did this morning is flush the cache on the website and clear my browser cache, why would that cause an issue with WP editor now? Anyone??? Please -- really need this fixed.


Ugh -- all I had to do was clear cookies and my cache? How do I stand upright and walk? Such a silly thing and I had no idea. 

Hey @travelshopgirl


First let me say welcome to the community! Smiley Happy


I may be misunderstanding from your last post and update, but it sounds like you might have worked out the issue? Generally, if the only one browser is having continuous issues it's often corrected by clearing cache or even disabling any third party plug-ins/toolbars your browser may be using. 


Let us know if you're still needing help. 

CG - GoDaddy | Community Moderator
24/7 support available at