Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jmander
New

Contact Forms not Sending Emails

Hello,

 

I have an issue where if someone completes and submits a contact form to me the emails aren't coming through.

 

I was told by GD support to follow the steps in the article "Send form mail using an SMTP relay server" however I can't see how I make these changes to my WordPress website.

 

Both my website and domain is with GoDaddy so I'm not sure why it's not working properly.

 

Your help is appreciated before my website launches next weekend.

 

Thanks,

 

Joe

2 REPLIES 2
PL281
Super User IV

@jmander 

 

1) Is this on Managed WordPress or cPanel

2) Is the email at the domain or gmail or something else?

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

PMH_Tokyo
Getting Started

I was alerted to the fact my web-forms were not working by accident and I have been tracing this back for the last 24 hours.  My code had not changed since 2016.  

After lots of hunting I found that the form probably stopped some time in April (business is slow because of covid) and I also discovered a new version of Php (v7) kicked in around that time.  After lots of experimenting with the php mail() function, I went back to php v5.4.45 and the form is working again.  You could try that - for me, a simple change in in the plesk interface.

However, it still does not explain for me why php v7 broke the mail() function. 

Postscript: I was thinking about this more and decided to check the phpinfo() page between the different versions (a side by side for 5.4.45 and 7.3.29).  The act of forcing plesk to re-create the files for 7.3.29 meant that my contact form now works again.  Go figure.  Nothing actually changed other than changing versions manually.