Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MichaelO
New

Deluxe Hosting cannot install unique WordPress sites in subfolders of root correctly

I upgraded to the Deluxe hosting so that I can have 4 urls hosted by Godaddy on my single hosting site. I installed WordPress in separate folders named the same as the URLs (silvercroneyoga, silvercroneskitchen, wanderlustarts, wizenedwarrior). The URLs point to these subfolders of the root (E.g. www.silvercroneyoga.com points to the /silvercroneyoga folder). When I go to Wordpress, the HOME page loads fine, but ALL subpages are 404 not found. It is as if each WordPress install did not configure to use the site urls that point to those subfolders.

 

Shouldn't WordPress consider EACH url as a separate site? This is why I upgraded to deluxe: to host 4 sites with the same hosting account. Why can't WordPress find any pages on each site other than the home page?

6 REPLIES 6
JMPepper
Advocate VII

Hi @MichaelO,

 

Here are a couple of quick checks to start the process.  If you haven't done so, check your settings for the URL and Site Address under the Settings>General dialogue.  Make sure they match what they should be for your site.

 

Sometimes, permalink settings can cause problems.  Check the documentation and see if your theme or any plugin has required settings.  This happened to me once.  I struggled for 2 days trying to figure out the problem.  I was the problem - the documentation says - use this plugin.....!!

 

Did you do a complete manual install or did you use the installatron?  When I do a cPanel installation I usually use do a complete manual installation since it takes so little time and during the installation I'm sure to see how the install progresses.  I've used this technique to install several sites on a single Deluxe hosting and never had a problem.  Even though the installatron gets the installations right most of the time, sometimes it's not quite a perfect as it should be!

 

Hope this helps,

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

Hi @MichaelO,

 

Also forgot to mention -- make sure that your DNS settings are correct!

 

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

None of these post are helpful at all. "Check this..." Yes, but what should it be? Specifics. GoDaddy help is NOT helpful.

Hi @monicastarr,

 

I went to all of your sites and am not getting a 404 error anywhere and all looked good.   Is this happening only when you are logged into your WP dashboards?

 

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

Apparently I can not work on my site today I have to wait 48 hrs for it to propagate.

Another thing to check is the .htaccess file. You will need to have that file in the root of each domain. 

If you are missing the .htaccesss file with the content below that will interfere with Settings > Permalink settings and cause the 404 errors. You will need to change RewriteBase to match the location of Wordpress if not in the root folder for the domain. You should not need to change this as it should be set correctly for your sites. 

 

Save to file named .htaccess and place in the root folder for each of your domains with Wordpress installed.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase / 
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress/index.php [L]
</IfModule>
# END WordPress