cancel
Showing results for 
Search instead for 
Did you mean: 

Don't see sites added in WP Multisite

Hi, 

I have a problem with multisite. I've setupped WP Multisite using GoDaddy tutorial, added necessary lines to wp-config and rewrote htaccess with:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

 

Later I've added a new site but I can't see it in "My Sites". I see it when I go to Network Admin > Sites, but when I try to click Visit on it - it goes to my primary site.

 

I use subcategories, so my primary site is: citradi/com and my second site is citradi.com/domestic.

 

Any ideas?

4 REPLIES 4
Super User I Super User I
Super User I

Re: Don't see sites added in WP Multisite

I'm a virtual WordPress rookie but one mistake I have made in the past is not making sure that the account I am logged in with is also and account that can access the other subsites. I'd start with checking permissions just to make sure they are correct. Other than that it seems like you have crossed every T and dotted every i? I hope that helps?

...turns out that my two cents is worth less or more depending on the current exchange rate.

roy darling *my posts seem a lot shorter in my head

Re: Don't see sites added in WP Multisite

Thanks, you had right with user permission. I filled user emails in multisite sites with others than Network Admin's email. 

I see sites in "My Sites" now, but they still have the same link: citradi.com instead of citradi.com/domestic etc. (like subpages are called).

 

What do you mean "Other than that it seems like you have crossed every T and dotted every i? I hope that helps?"

 

 

Super User I Super User I
Super User I

Re: Don't see sites added in WP Multisite

My first guess was just what I suggested just because I've done that before. With the information you provided it appeared that you had done everything else properly? 

 

You should have a website at your /domestic domain. I assume that you have a default template selected for your subsite? Can you access the admin of of the subsite @Zyggmunt?

...turns out that my two cents is worth less or more depending on the current exchange rate.

roy darling *my posts seem a lot shorter in my head

Re: Don't see sites added in WP Multisite

Hoping to bump this question up as I've got the exact same problem. I see the additional sites listed, but when I try to add a post or navigate to the 'new' site, it just goes to the primary site.