Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error when installing Jetpack on Managed WordPress

I have a started managed wordpress account which I have had for a few years with no major issues. I have used Jetpack for those years as well. Last night I attempted to run the plugin's update which resulted in the site being down for server maintenance temporarily then when it came back online Jetpack was no longer installed.

Upon trying to reinstall it manually I receive the following message:

"Installation failed: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> 500 Internal Server Error Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator and inform them of the time the error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log."

Any ideas?


I have the same issue. When to update Jetpack which I'm not using and got the same error message but can't access my site at all, front end or back end, Completely down and inaccessible. Have opened ticket with GoDaddy to get it resolved, but what on earth was in that update?

Just adding a "me too." I've removed the plugin manually and was able to bring my site back up. Hopefully this will be fixed soon!

Oh I'm glad you're back up and running! I couldn't even get into my admin to do that so totally did it wreck the site. Thankfully GoDaddy got it back up overnight so relieved and getting rid of Jetpack now.

I've been having the same problem as well on Managed WordPress, after years of using Jetpack with my site. Two days ago, apparently a Jetpack update failed. I only noticed it when yesterday Jetpack ceased to appear in my plug-ins list after a cryptic Jetpack error message when I opened my WordPress dashboard.


Repeated attempts to reinstall Jetpack yesterday and today have also failed, leading to messages such as:

"Installation failed: Inactivity Timeout Inactivity Timeout Description: Too much time has passed without sending any data for document."


"Installation failed: Connection lost or the server is busy. Please try again later."


I've used FileZilla to go into my WordPress file system via SFTP and the Jetpack plug-in folder is there. I deleted it and tried to reinstall, but it still doesn't work. So I deleted the Jetpack plug-in folder a second time in case a later clean install actually works.


My site itself is still up and running. I can't tell if this is a misconfiguration between how GoDaddy handles Jetpack and how the latest version of Jetpack updates/installs, or if there's some serious problem with the latest update to Jetpack.