cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New

Fetch as Google returns "Not Found"

Hello,

I have a problem which caused massive traffic drop.
All posts under this page http://stieglarsson.com/discussion-board/  are returning "Not Found" on fetch as Google.
The posts are completely accessible but as I told you, Google fetch is returning "not found".
All other pages / posts on the site are working just fine and returning "Completed" on fetch.
Please see this image.
Thanks in advance for your support!
4 REPLIES 4
Super User II Super User II
Super User II

Re: Fetch as Google returns "Not Found"

@xpetru

 

I noticed that the discussion-board link appears to redirect to itself.   Do you have any plugins redirecting?   Have you checked your .htaccess file?

 

 HTH! Smiley Wink

Judith
"Do one thing every day that scares you." ~ Eleanor Roosevelt

New

Re: Fetch as Google returns "Not Found"


@Muse wrote:

@xpetru

 

I noticed that the discussion-board link appears to redirect to itself.   Do you have any plugins redirecting?   Have you checked your .htaccess file?

 

 HTH! Smiley Wink


Hi,

Thanks for taking your time to look on it.

Yes, I checked the htaccess but it does not seem to be the problem (I emptied it and fetched again with same result).

I do have a plugin for redirections - but none of them redirects the discussion-board link to itself. I also deactivated all plugins but the problem did not disappear.

Also - how did you find that the discussion-board link redirects to itself? 

 

Thank you!

Super User II Super User II
Super User II

Re: Fetch as Google returns "Not Found"

@xpetru

 

I noticed the redirect when I went to the URL...  It is Google redirecting you -- look at the URL and message in the attached screenshot.  After that appears your page then displays.

 

HTH! Smiley Wink

Judith
"Do one thing every day that scares you." ~ Eleanor Roosevelt

New

Re: Fetch as Google returns "Not Found"


@Muse wrote:

@xpetru

 

I noticed the redirect when I went to the URL...  It is Google redirecting you -- look at the URL and message in the attached screenshot.  After that appears your page then displays.

 

HTH! Smiley Wink



I don't know what's happening.

Anyway - the discussion board main page looks good - it returns 200 OK.

But all pages that are linked to it return 404 Not Found

all pages like these below

http://stieglarsson.com/discussion-board/doctor/

http://stieglarsson.com/discussion-board/salanders-mistake/

http://stieglarsson.com/discussion-board/product-placement/

all of them (500+) that are under the /discussion-board/ - return 404 Not Found