cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution
Helper I
Helper I

How to remove HTTPs

I transferred a WordPress website to another account by buying WordPress hosting for that account. Originally, the site was in HTTPs, now it will be in HTTP in the meantime. How can I make it so? Whenever I'd type the URL in, it will take me to the HTTPs version. I've had someone redirect my domain from HTTP to HTTPs before so I don't know how to switch it back.

 

Can someone please help me? I looked at similar questions here on Godaddy, and they say that the answer is within the .htaccess file. But, the text I have on my .htaccess is different. 

 

This is what I have inside the .htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Do I need to add something into this? If not, is there something else I need to do for it to stop redirecting to HTTPs? 

4 REPLIES 4
Community Manager
Community Manager

Re: How to remove HTTPs

Hi @aafable. Redirects from HTTPS back to HTTP are a little tricky. Essentially a normal redirect follows this process:

  • A URL is entered and resolves to an IP.
  • When the client arrives at the IP, the server loads files and communicates a redirect is there. 
  • The browser is then redirected to the new URL.

In the case of accessing a URL when HTTPS is included, a different port is used (443). The port is only accessible if SSL traffic is enabled. If it isn't, the server can't be accessed and the redirect doesn't load. Basically, the only way to redirect from HTTPS to HTTP is to have an SSL Certificate installed so HTTPS traffic can be enabled. 

 

If you're not intentionally entering HTTPS when you visit the URL, your browser may be cached to resolve it that way. You can try clearing your cache to see if that helps. Otherwise, you may also want to check to make sure the WordPress site itself isn't set up within its database/settings to use a URL that has HTTPS specified. Hope that helps. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.
Resolver I
Solution

Re: How to remove HTTPs

Bear in mind that many of your URLs are set in the database. Any upload to the media section, links, etc. are all set in the database and need to be replaced.

 

You can use a script like this one to accomplish the task:

https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

 

This script will run on your database and replace any given string so you can run it and replace any occurrence of "https://www.yourdomain.com" with "http://www.yourdomain.com".

 

This usually solves all https/http issues related to Wordpress site transfers.

 

Make sure to read the README file and fully understand what you are doing before running the script, and obviously backup your database before.

 

I hope this helps! If it does, please hit that Kudos below :-)

Helper I
Helper I

Re: How to remove HTTPs

Thanks. I couldn't figure it out so I just hired someone from Fiverr to do it. Thanks for your input!

Re: How to remove HTTPs

I also had the same issue, deleted my GoCentral website. Thinking I was clearing my domain, then when I added my domain name to a fresh WP site it was set to direct to HTTPS. Making it impossible to access my URL. I'm going to call GoDaddy and ask them to "revert domain name to defaults" or something along those lines. Any tips would be much appreciated.