Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Inactivity Timeout Description: Too much time has passed without sending any data for document.

We are using a Managed WordPress environment to run a website - and this had been running without problem until a couple of days ago. We then hit a problem as we started to get "Inactivity Timeout  Description: Too much time has passed without sending any data for document." messages when trying to access the WordPress dashboard. We actually cannot access any admin feature and so cannot add content or even edit existing content. We've contacted GoDaddy support on 7 occasions (10+ hours so far of phone/web chat conversations) and too often they have made the problem worse by reducing memory limit to 256M - so the site suffers memory exhausted errors and completely fails. Has anyone here got any ideas on this issue?


I had the same issue, and here's what worked:


Add the following line to your wp-config right at the beginning.

           define('WP_TEMP_DIR', ABSPATH . 'wp-content/');


then flush the cache.



View solution in original post


I'm still having this issue but have noticed that if I refresh staging from production then I can access the WP Dashboard on Staging. To me this suggests that there is an issue on the production environment....

Im having this issue too. Did you resolve it? If yes, can you tell me how?


I'm trying to optimize images on my site.  Getting this error: Description: Too much time has passed without sending any data for document.


Can someone from Godaddy look at the issue?  Also what happened to the chat box that was available to me a week or two ago?


Having same issue! cant access any admin features now


Bump... Same here. Client reported timeout issue and sluggish admin. Strangest thing was this only occurred on a specific page. Tried the Plugin/Theme disable all/re-enable one at a time. Wordfence is clean, tried Succuri too, all good. 

Duplicated the page, can access in editor. Line for line same as old page. Trashed/perm delete old page, rename and change permalink for new page, editor still accessible. I have absolutely no explanation. I think this is being reported by enough WP Managed users to warrant a peek at the logs. Something is definitely going on server side. I see tons of flickering 302 issues being reported when the browser is trying to connect to post.php. Any recent modifications to GoDaddy's config plugin for WP or policies on the managed WP platform servers?

I’m having the same problem on my site, too.


GoDaddy said it must be my theme/plugins, but I deactivated all plugins and changed the theme and it’s still happening.


Same issue trying to update products in bulk, c'mon GoDaddy, please help!

I am experiencing the same issue on my production server. Godaddy support is useless on this issue. I completely blew up my site and started over from a completely fresh installation. Here is the behavior I experienced:

I installed a Thimpress/ WooCommerce theme that required several other plugins. I tried to install them all at once, only to get a bunch of failure notices and timeouts. I tried to install them again, only to get errors that said "bad header" and the "folder already exists." I looked on the FTP site and saw that indeed the files had been copied, but the system did not recognize the plugins as installed. I deleted each folder and reinstalled the plugins one by one. This approach worked until I reached Revolution Slider, which is apparently a large plugin. That's when I get the Inactivity Timeout error. Thus, it appears to be a memory or execution time error.

My .user.ini settings:


memory_limit = 512M
max_execution_time = 3000
post_max_size 64M
upload_max_filesize 64M


The timeout error occurs long before 3,000 seconds (50 minutes), which tells me that either Godaddy has their own limit I cannot override, or the file size is larger than 64MB. I changed my

.user.ini settings, and tried again:

memory_limit = 512M
max_execution_time = 3000
post_max_size 128M
upload_max_filesize 128M

Instead of getting a timeout error, this time I received the error, "Sorry, you are not allowed to access this page." after about 1:45. I confirmed that "revslider" was uploaded to the plugin folder (as usual). I then refreshed the page. Slider Revolution was successfully installed.

So, apparently the solution is to increase either post_max_size and/or upload_max_filesize to something really big like 128M, and then it will sorta work.

I have one other action that causes the same timeout issue that I will see if this solves.


I just realized that I forgot an "=" sign in my .user.ini file. So I'm not entirely sure that fixed the problem.


I am having the issue on one of my WordPress sites as well, started sometime Wed. 2/8.  GoDaddy support seems clueless - two different techs, two different responses:

Tech1: deactivated plug-ins via FTP - no effect

Tech2: restarted server - no effect


Using Managed WordPress backups from my dashboard, I was able to clone the site to a temporary location, and all is working fine there, so the issue is not with the site or the plug-ins, rather something on the server on which it is hosted.


Of course, if find a good solution here, I will implement that as well.

I am likely (at least for the time being) re-point the domain to the temp server site until they can figure out what is going on with it.

Finally getting somewhere on mine....apparently a plug-in causing some caching.  I will check more and see what I can find.

I am also having the same issue.  Godaddy says the same things  - it must be the theme and plug-ins - though this JUST STARTED a few days ago and we don't have anything super crazy going on.  This is ridiculous.

I actually hired two different consultants to speed up my site - both of them told me to switch hosting.  One said that the only thing Godaddy is good at is marketing.   

Now, they're wrecking my business.  

Please let us know if you figure anything out.  Thank you. 

I'm having the same issue. We found out today while  trying to access our admin dashboard. Errors everywhere about inactivity or everything lasts forever. No changes that we can recall of (maybe some  automatic plugin update?). I'm seriously considering switching hosting if I can't fix this.

We switched hosting to Site ground and never experienced this issue again



Well, In my case, though it said all that nonsense about it not installing and all, It had actually installed... Just didn't prompt me that it did.


So go to your Plug-ins and activate it. It should be there. 


Yoast SEO 7.0.3 update just tripped me up; could no longer see All Products.  Deactivated for now and all is fine (except no SEO for now).

I'm experiencing the same issue amount my 10 or so websites. Periodically the error appears:
Update Failed: Inactivity Timeout Inactivity Timeout Description: Too much time has passed without sending any data for document.


An example while trying to update a plugin that has 2 million active installations:
That's not cool!

In most cases, my sites have only 5 or fewer plugins installed and I'm very good at removing all of my inactive plugins and themes as well. I've never seen this recurring behavior at my other hosts.

Looking forward to hearing whether anyone finds a "solution" to this Godaddy Managed WordPress out of memory issue.

I've had this issue once a week, going on three weeks now. It's happening again today. I've called support and they fix it, but the fix only works for a week. The last person I spoke didn't know what he was doing, therefore, didn't know how to fix it or what was going on. He put me on hold a few times, but I think he was just sitting there twiddling his thumbs.


Very poor service from GoDaddy. I have Basic WP Manage, but they want me to but the upgraded WP manage support and I'm not going to. Once I get funds together I might be moving to Bluehost.

I had the same issue, and here's what worked:


Add the following line to your wp-config right at the beginning.

           define('WP_TEMP_DIR', ABSPATH . 'wp-content/');


then flush the cache.



View solution in original post


I was referred to this thread by a customer service rep for Go Daddy. They aren't allowed to make changes to files and I'm confused on where the "beginning" is located at in wp-config. 

Is it literally at the beginning where it looks like this?



* The base configuration for WordPress

Or is it further down at the beginning of a series of code that looks like this?

// ** MySQL settings - You can get this info from your web host ** //

/** The name of the database for WordPress */

define('DB_NAME', 'removed this piece of code for privacy concerns');

I'm doing this myself because I've had the same exact problem for 8 months. After at least 10 calls to Go Daddy, nothing is resolved. Many reps blame the plugin developers, however, now the error code pops up on almost all plugin updates. The blame-game doesn't fly. This is a Go Daddy issue on that problematic WP hosting package and I believe it has a lot to do with Go Daddy's caching system. 

Help with pasting this code in the appropriate "beginning" area is greatly appreciated and with much thanks from the bottom of my frustrated heart.  I have a business to run, just as everyone else does. These problems needed a permanent and successful resolution 8 months ago! I can't deal with this anymore and will move to Bluehost. Up until this timeout issue, I didn't have a complaint about Go Daddy but ongoing nature of this major issue causes far too much downtime for every customer  dealing with this janky BS. 

Thank you, 

My opinion, based on 25 years experience, is that GoDaddy jams too many people onto the same physical servers that we share. On top of that, they restrict PhP values so that we have no bandwidth and timeouts everywhere.


From that point, you need to understand HTML or at least know how to tinker with WordPress files via an FTP's a nightmare.


The "go to" lie will always be "It's your theme developer's problem". Yeah great. Obviously, everyone that buys a domain to build a website will have a theme and then the blame game is easy.


Bottom line is that GoDaddy is cheap, and minus a class action lawsuit, which individual user is going to tell them to fix their cheapness?