cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New

Issue with installs on Plesk

Dear Sir/Mdm,

 

I am using Godaddy's Plesk Hosting. Windows Server for my wordpress install. When I try to install a plugin via Wordpress backend I get this huge line of errors. I added .user.ini into my root folder as advice by Godaddy support but it still didn't work. Please help.

I have never faced such an issue from a Fresh Wordpress install with any other web host. Installing plugins from a fresh Wordpress install should never have an issue. I'm really not sure what else to do!? 

Installation failed: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> IIS 8.5 Detailed Error - 500.0 - Internal Server Error <!-- body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;} code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;} .config_source code{font-size:.8em;color:#000000;} pre{margin:0;font-size:1.4em;word-wrap:break-word;} ul,ol{margin:10px 0 10px 5px;} ul.first,ol.first{margin-top:5px;} fieldset{padding:0 15px 10px 15px;word-break:break-all;} .summary-container fieldset{padding-bottom:5px;margin-top:4px;} legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;} legend{color:#333333;;margin:4px 0 8px -12px;_margin-top:0px; font-weight:bold;font-size:1em;} a:link,a:visited{color:#007EFF;font-weight:bold;} a:hover{text-decoration:none;} h1{font-size:2.4em;margin:0;color:#FFF;} h2{font-size:1.7em;margin:0;color:#CC0000;} h3{font-size:1.4em;margin:10px 0 0 0;color:#CC0000;} h4{font-size:1.2em;margin:10px 0 5px 0; }#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS",Verdana,sans-serif; color:#FFF;background-color:#5C87B2; }#content{margin:0 0 0 2%;position:relative;} .summary-container,.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} .content-container p{margin:0 0 10px 0; }#details-left{width:35%;float:left;margin-right:2%; }#details-right{width:63%;float:left;overflow:hidden; }#server_version{width:96%;_height:1px;min-height:1px;margin:0 0 5px 0;padding:11px 2% 8px 2%;color:#FFFFFF; background-color:#5A7FA5;border-bottom:1px solid #C1CFDD;border-top:1px solid #4A6C8E;font-weight:normal; font-size:1em;color:#FFF;text-align:right; }#server_version p{margin:5px 0;} table{margin:4px 0 4px 0;width:100%;border:none;} td,th{vertical-align:top;padding:3px 0;text-align:left;font-weight:normal;border:none;} th{width:30%;text-align:right;padding-right:2%;font-weight:bold;} thead th{background-color:#ebebeb;width:25%; }#details-right th{width:20%;} table tr.alt td,table tr.alt th{} .highlight-code{color:#CC0000;font-weight:bold;font-style:italic;} .clear{clear:both;} .preferred{padding:0 5px 2px 5px;font-weight:normal;background:#006633;color:#FFF;font-size:.8em;} --> HTTP Error 500.0 - Internal Server Error C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP56\php-cgi.exe - The FastCGI process exceeded configured request timeout Most likely causes: IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred. IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly. IIS was not able to process configuration for the Web site or application. The authenticated user does not have permission to use this DLL. The request is mapped to a managed handler but the .NET Extensibility Feature is not installed. Things you can try: Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account. Check the event logs to see if any additional information was logged. Verify the permissions for the DLL. Install the .NET Extensibility feature if the request is mapped to a managed handler. Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here. Detailed Error Information: Module&nbsp;&nbsp;&nbsp;FastCgiModule Notification&nbsp;&nbsp;&nbsp;ExecuteRequestHandler Handler&nbsp;&nbsp;&nbsp;PHP-php Error Code&nbsp;&nbsp;&nbsp;0x80070102 Requested URL&nbsp;&nbsp;&nbsp;http://zanetta.co:80/wp-admin/admin-ajax.php Physical Path&nbsp;&nbsp;&nbsp;G:\PleskVhosts\zanetta.co\wordpress\wp-admin\admin-ajax.php Logon Method&nbsp;&nbsp;&nbsp;Anonymous Logon User&nbsp;&nbsp;&nbsp;Anonymous More Information: This error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error. View more information &raquo; Microsoft Knowledge Base Articles: 294807

 

2 REPLIES 2
Highlighted
Community Team
Community Team

Re: Issue with installs on Plesk

Hello @Moses, there's a lot of information in that error, however without knowing how you've set up your hosting and what else you've added, it's impossible to identify the exact cause.  My recommendation would be to contact our live support so we can review your hosting plan in more detail and run some real time tests with you on the line.  Please give us a call at your earliest convenience and we'll help get to the bottom of the error with the installation of plugins.  

 

Thank you!

MPC

Highlighted
New

Re: Issue with installs on Plesk

Hi, I'm having the same issue, the error is this: 

 

The FastCGI process exceeded configured request timeout

 

this is because the following values have to be adjusted in the fcgiext.ini file, which Godaddy manages:

 

RequestTimeout=
ActivityTimeout=

 

they have to be set to something larger, I think the default value is 30 seconds.

 

Godaddy, please help me fix this.