cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Missing YouTube thumbnail on my website

Hi -

I have two similar websites, both using the Enfold theme (v4.21), and similar in content. My problem is that the thumbnail for the same YouTube link is present on one website, but not the other. As far as I can tell, they were both set up exactly the same. I'm including photos for comparison. The third video on the right is the same for both sites, but you can see the problem. Any advice on how to fix this would be greatly appreciated.

Screen Shot 2019-06-03 at 11.48.54 PM.png

Screen Shot 2019-06-04 at 12.00.23 AM.png

3 REPLIES 3
Super User III
Super User III
Solution

Re: Missing YouTube thumbnail on my website

@sevenisblue 

 

I can see from your screen shot that the video missing the image is using the youtu.be URL - I find that with WordPress and YouTube you need the full youtube url or sometimes not all the settings get pulled in correctly



I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Re: Missing YouTube thumbnail on my website

Thank you so much, @PL281!

This did the trick!

Re: Missing YouTube thumbnail on my website

Hi

 

Even I was facing the issue. Your solution was of great help. Thank You @PL281