Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Getting Started

Service Unavailable 503 Error



Please move this thread into the relevant topic if this is the wrong one..


Since setting up my website

I have had nothing but 503 Service Unavailable errors..
The Wordpress managed site has only been installed a week... for the first couple of days worked fine..
Been unsuable for 3 days now...

Tried several different machines (from different IP addresses) and every browser going.
Does the exact same on mobiles using Wifi or 4g

Rang the support team [was on the phone for 50 mins] They replicated the problem and then cut me off when trying to put me through to the Host Support..

Can anyone give me any help on this it's doing my f**king head in



Community Manager

Hi @Aaarrrahh@Faheemk@tomharte@bharat1411, 503 errors generally mean that there is a resource limit for the hosting account that is being met. For the most part, this doesn't usually happen for Managed WordPress accounts and is more common with cPanel, Plesk, or Web & Classic hosting plans. The way to address the issue depends on the platform you're on. 



Most of the time, you will see 503 errors when the RAM for the account is hitting its limit. You can check the limits for a cPanel account by visiting the CPU and Concurrent Connections Usage tool under Metrics. The easiest way to address this type of issue is to to use a caching plugin or try changing/disabling your themes and plugins. 


Plesk, Web & Classic hosting

Unlike cPanel, there isn't a way to view the statistics for resource usage on these accounts. However, addressing the issue is usually done the same way, by adding a caching plugin, or changing/disabling your themes and plugins. 


Managed WordPress

Because it has a built in caching system, Managed WordPress accounts don't usually generate 503 errors due to RAM usage. When it does occur, it is most often tied to having too many database connections. For these plans, you can have up to 25 simultaneous database connections. Since WordPress is fairly database dependent, this limit can be reached fairly quickly depending on the type of theme and plugins you're using. (There are Pro Managed WordPress plans, also known as Managed WordPress 2.0, which increase this amount, but these are still in the beta phase.) The best way to troubleshoot this is to try changing/disabling your themes and plugins. 


For any of these hosting plans, it is possible that the 503 errors are related to an issue with the server itself. This is fairly uncommon, so you'll want to check the above first. If you've already checked these things and are still seeing a 503 error, then you'll want to get in touch with our support team so they can take a look at the account. 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.

View solution in original post

Getting Started

Same for me buddy, up and down all over the place support are being less and helpful and to wait it out.  While we lose business and customers...A complete shambles

Advocate VII

Hi @Aaarrrahh,


I was able to get the site to load.  Check your memory and php resources.  They are often the culprit on 503 errors because the site does not have the resources allocated to respond quickly.  How you change these settings depends on your hosting.


It basically requires and update to the wp-config.php file and the user.ini file.  Here is a link to how to do this:


Be sure to flush cache after you've made the updates.


Hope this helps,


Not Just Pretty Sites, Pretty Doggone Smart Sites

James a lot of people are reporting the same 503 issues, GD have identified its an error server side and they are working on the issue, how does updating the memory limit help if there's a server issue.  Thanks, Tom



Have you a link to this identified error please?
Just for my own record




Our site has been up and down the past few days and no resolution from GD...We normally get this


503 Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Exactly the same..


Now me website says "Cannot be reached. The connection was reset" Check proxy bla bla bla

and now is infinitely trying to load the front page


Finally failing with:


504 Gateway Time-out

The server didn't respond in time.

This is crazy

Modified my wp-config.php to 


define( 'WP_MEMORY_LIMIT', '256M' );


Seems to have loaded the website at the moment..
Can you try it please

Also: How do I perform a flush cache pls


Thanks for your response


You flush the cache from the dashboard

Your site is loading....did you ftp to modify the wpconfig file or go through the dashboard?

FTP Modified Tom

Cool...been checking your site along with mine, still very slow...I am dubious the memory mod will work as I have been had numerous discussions with GD and they have stated its server side error...So said to wait it out, I asking for compensation...ignored that lol

Least you have managed to contact them - 45 mins waiting in a queue and got fed up of waiting

and no i dont think the config file mod makes any difference

I went virtual chat every time had no issues although I don't think putting everything in CAPS expressed how frustrated I was lol

I think I will try a virtual chat tomorrow... 
then maybe a remote cliff which I can jump off.. glad I only opted for a 3 month trial as it stands


I am facing same issue. Can someone help me with solution

Would anyone from GD like to comment on this please

We seem to be back in the room...Hopefully, I'll light a candle lol

lol..theres no hearing on customer care support also..they are saying that our server is on upgradation and your website should be live in couple of hours ..this thing since 3 days they are telling..totally edited.

Yours does come up with something.. looks like maybe your plugin failed to update or something you have loads of errors 


Mine still down most of the day and comes up when it can be bothered


Update: Today mostly it has been working brilliantly.. 
Even managed to add a few more blogs