Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Getting Started

Too Many Redirects / Cloudflare

Hi there, I've got a rather baffling issue going on with one of my sites under Managed Wordpress. I'm using the free tier of Cloudflare on all 3 of my sites, but starting about 2 weeks ago, I awoke to one of my sites down with a "Too Many Redirects" error.

After a bunch of troubleshooting, I determined the problem was with Cloudflare, as when I paused the Cloudflare service for the site in question, gradually the site became available again.

I did some DNS tinkering as I completely deleted the site from the Cloudflare account, and then readded it. After DNS went through, the site was back up and running, getting the CDN benefits of Cloudflare.

Now, almost exactly one week after turning Cloudflare back on for that site, I had the same "Too Many Redirects" issue come up again. And once again, pausing Cloudflare is the only way I could get the site to load without the error.

I'm at a loss. The only thing close to this in the Cloudflare "help" involves a redirect issue with sites using SSL / https, which the site in question does not use yet.

Things I've tried:

- The usual disable plugins / change themes / etc. stuff did not work. I could still access the wp-admin the entire time, but for brief periods, the backend icons (ie. GoDaddy glasses guy, Jetpack, etc.) loaded as broken images - which I thought was really weird. I have Cloudflare set to NOT cache the wp-admin via "rules" there so I don't believe CF was the issue there. 

-Deleting the site from the Cloudflare dashboard, changing DNS back to GoDaddy, then readding the site following the Cloudflare instructions. Again, this worked for almost exactly 7 days to the hour before giving me the "Too Many Redirects" error once again.


- Restoring the site from backups did not fix the issue whatsoever

Strangely enough, my other two GoDaddy Managed WP sites have identical Cloudflare settings but are not experiencing this issue. However, they are on different GoDaddy IP addresses than "", the site that I'm experiencing this problem on.


Any insight on this issue would be greatly appreciated. Obviously, if there is no fix I suppose I can handle the site loading in 2 - 3 seconds as it does without the CDN, but I'm hoping I'm missing something obvious that can fix this issue.




Going full strict on cloudflare fixed it for me too, 

View solution in original post


Hey @benjaminarp


I did a little digging online for this error in relation to Cloudflare services and came across this recent post on their own forums. Any chance this was the SSL article you were referring to finding on your own? I've also come across other posts on WordPress Forums and StackOverflow that indicate similar issues with Cloudflare and mixed content using SSL rewrites. So far, everything I can find points to the same possible causes. 


Have you tried either of the two suggestions already posted on the Cloudflare forum? Beyond that, I honestly don't know what else to suggest beyond reaching out to Cloudflare support directly for further solutions. 


CG - GoDaddy | Community Moderator
24/7 support available at

Hello Benjaminarp,


I'm having the same issue and I tried almost every troubleshoot to solve this error. But When I change SSL to Full (Strict) from Flexible then I can access my website without having any issues. So, I think you should also try it. I hope it might help you.


Thanks & Regards,

Lokesh Aryan

Founder & Blogger at

Email ID:

Going full strict on cloudflare fixed it for me too, 

View solution in original post