Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 

White screen of death

Hi there,


My website is experiencing the white screen of death and I am unable to access the login page to my Wordpress site as it is also blank. I've been reading various help guides and they advise disabling plugins via the cPanel or FTP but I can't access these either as I only have a Wordpress managed plan through GoDaddy. I'm confused as to how I can resolve this?


When I click on the 'manage' option for my website within the GoDaddy dashboard the screen just goes blank too.


Any help would be much appreciated!

Super User II

Here are the steps to use FTP with a Managed WordPress plan.

Hi Nate - thank you for replying, I will take a look 🙂

Super User 2020

It's almost certainly a plugin or theme causing the issue.


Here are some troubleshooting links that will be helpful.


Troubleshoot and fix theme errors.

Troubleshoot and fix plugin errors.

Troubleshoot and fix WP core errors.


Temporarily turning on the wp-debug will help tell you what, exactly, is causing the issue.


I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

I have two websites uploaded on a server. I upgraded to a server with 4GB of Memory 

Tonight I was adding some plugins to one site, while adding basic word press entries on the other. All of a sudden the one where I was just adding word press entries is a white screen.  I've tried various web browsers with the same result.  I haven't adjusted anything on the site that isn't showing up except for basic entries.  I tried deleting recent entries to see if that helped and it didn't. I am now restoring the backup from earlier today to see.  Could this be caused by the additions on the other site?