cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted
New

htaccess file redirect

Hey Guys,

 

I hope you guys can help because I have no idea how to fix this.

 

I have my site at www.okoz.eu

I decided to create a clone and put it in a folder called nl under the root directory of my site that is called okoz.

now there are  2 sites: www.okoz.eu and www.okoz.eu/nl

in the root directory, there is an htaccess file that directs all incoming traffic from HTTP to HTTPS.

now every time Igo to www.okoz.eu/nl I am getting to www.okoz.eu.

I suspect it is the redirect in the htaccess file causing this issue.

 

Any idea how can I fix this?

 

Cheers,

Vic

 

6 REPLIES 6
Super User III
Super User III

Re: htaccess file redirect

Can you send the redirect code you have in the htaccess file in the NL folder - more than likely if you cloned the entire site that is the issue that you need to add the nl to the redirect to the htaccess file in the nl folder



I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

New

Re: htaccess file redirect

Hi,

 

Many thanks for your reply, much appreciated.

 

Indeed you are correct, I have made a change to the file with the help of GoDaddy support.

 

It is still not working yet, but according to the support, it will take time just like a DNS change.

 

Here are the changes do you think they are correct?

 

RewriteEngine On
RewriteCond %{HTTP_HOST} okoz\.eu [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.okoz.eu/$1 [R,L]

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /nl/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /nl/index.php [L]
</IfModule>

# END WordPress

 

Cheers.

 

 

 

 

 

 

Super User III
Super User III

Re: htaccess file redirect

1) htaccess changes should be pretty much instant as it's a local file not a DNS update

2) right now I can't get to the main site even

3) If what you pasted in your response is what you have in the htaccess file for https://www.okoz.eu/nl

then you need to add the nl into the rule and condition 

 

Personally I wouldn't do this via htaccess, I would use the plugin "Really Simple SSL" which will do re-writes on all the content and help to get rid of mixed content issues

 

 



I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

New

Re: htaccess file redirect

Hi,

 

Since he did the change I am unable to reach my sites anymore not even the backend.

 

I am calling the support again to see what they can do.

The only thing I can access is htaccess file via FTP now.

I also found it a bit strange about propagation time for htaccess but I am not knowledgable enough in that subject as much as he is I suppose.

 

here is my whole htaccess file:

 

no idea where it is going wrong.

 

RewriteEngine On

RewriteCond %{HTTP_HOST} okoz\.eu [NC]

RewriteCond %{SERVER_PORT} 80

RewriteRule ^(.*)$ https://www.okoz.eu/$1 [R,L]

 

# BEGIN WordPress

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteBase /

RewriteRule ^index\.php$ - [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . /index.php [L]

</IfModule>

 

# END WordPress

 

 

# BEGIN LiteSpeed

<IfModule Litespeed>

SetEnv noabort 1

</IfModule>

# END LiteSpeed

 

# TN - START EXPIRES CACHING #

<IfModule mod_expires.c>

ExpiresActive On

ExpiresByType text/css "access 1 month"

ExpiresByType text/html "access 1 month"

ExpiresByType image/gif "access 6 month"

ExpiresByType image/png "access 6 month"

ExpiresByType image/jpg "access 6 month"

ExpiresByType image/jpeg "access 6 month"

ExpiresByType image/x-icon "access 6 month"

ExpiresByType application/pdf "access 6 month"

ExpiresByType application/javascript "access 6 month"

ExpiresByType text/x-javascript "access 6 month"

ExpiresByType application/x-shockwave-flash "access 6 month"

ExpiresDefault "access 1 month"

</IfModule>

# TN - END EXPIRES CACHING #

 

 

#Disable Etags

<IfModule mod_headers.c>

   Header unset Etag

   Header set Connection keep-alive

</IfModule>

FileETag None

 

<IfModule mod_deflate.c>

  # Compress HTML, CSS, JavaScript, Text, XML and fonts

  AddOutputFilterByType DEFLATE application/javascript

  AddOutputFilterByType DEFLATE application/rss+xml

  AddOutputFilterByType DEFLATE application/vnd.ms-fontobject

  AddOutputFilterByType DEFLATE application/x-font

  AddOutputFilterByType DEFLATE application/x-font-opentype

  AddOutputFilterByType DEFLATE application/x-font-otf

  AddOutputFilterByType DEFLATE application/x-font-truetype

  AddOutputFilterByType DEFLATE application/x-font-ttf

  AddOutputFilterByType DEFLATE application/x-javascript

  AddOutputFilterByType DEFLATE application/xhtml+xml

  AddOutputFilterByType DEFLATE application/xml

  AddOutputFilterByType DEFLATE font/opentype

  AddOutputFilterByType DEFLATE font/otf

  AddOutputFilterByType DEFLATE font/ttf

  AddOutputFilterByType DEFLATE image/svg+xml

  AddOutputFilterByType DEFLATE image/x-icon

  AddOutputFilterByType DEFLATE text/css

  AddOutputFilterByType DEFLATE text/html

  AddOutputFilterByType DEFLATE text/javascript

  AddOutputFilterByType DEFLATE text/plain

  AddOutputFilterByType DEFLATE text/xml

  # Remove browser bugs (only needed for really old browsers)

  BrowserMatch ^Mozilla/4 gzip-only-text/html

  BrowserMatch ^Mozilla/4\.0[678] no-gzip

  BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

  Header append Vary User-Agent

</IfModule>

 

# BEGIN wtfdivi

 

 

 

 

 

 

 

 

 

 

 

 

 

 

# END wtfdivi

 

Cheers.

Super User III
Super User III
Solution

Re: htaccess file redirect

I would remove this code

 

 

RewriteEngine On
RewriteCond %{HTTP_HOST} okoz\.eu [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.okoz.eu/$1 [R,L]

 



I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

New
Solution

Re: htaccess file redirect

It seems that the support agent had changed the DNS.

 

It's back online but of course back to square one.

 

I will remove the lines and as you suggested and install really simple ssl.

 

I'll keep you posted.

 

 

Cheers.