Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

index.html in public_html directory but site is not showing it

I have a managed wordpress site with a theme installed.
I'd like to add my own files onto the homepage so this is what I did.
These are the files :
Folders: Fonts , lib, loading, media, skin
Files: fonts.css,  script.js, index.html

added all my files to public_html, then renamed index.php to indexxx.php (so that it doesn't get called), the edited .htaccess with code DirectoryIndex index.html, so that it looks for my index.html and have it do the work.
when I open the website it loads the wordpress theme that was initially installed and not my files.
I also noticed after ending filezilla session and accessing it again index.php shows up again but it's 0kb and empty
Tthe .htaccess has this line  DirectoryIndex index.html, so I'm confused and don't know ho w to fix this.
You help is greatly appreciated!


The current workaround the worked is if enter it works, therefore I just redirected to 

View solution in original post

Super User 2020



This may not be possible on the Managed WordPress platform. They have most of the files locked down to prevent changes due to a compromise. 


On this one, I would suggest contacting support and finding out if this is even possible on their MWP platform. You may have to move to a cPanel Linux platform to do this type of work. Even then you may need to hire a developer to help you out.

I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

It was working a couple of months ago, but suddenly after a couple of wordpress updates it stopped working. Those files represent a virtual tour, so the website was a virtual our only, no headers no footer etc..
I didn't even have cpanel , and now support wants me to purchase cpanel and transfer to there. 

There must be a simpler solution.


The current workaround the worked is if enter it works, therefore I just redirected to 

View solution in original post

I'm having the same issue.

I take in, and it gives me INSTEAD of index.html.

so the url is saying

If I just go up into the URL, and DELETE takes me to my site, AND IT'S ACTIVE.


BUT, not everyone will realize how to do this  😞


I just did the  #Alternate default index page
DirectoryIndex first.html 


so I'm now waiting for the server to reset, see if it worked.