• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    FTP Problems

    First, let me say I can use FileZilla to access my GoDaddy account just fine, no problems at all. But when I configure my DLink IP camera to FTP to my GoDaddy account, it works OK maybe once every couple dozen uploads. Most of the time it times out. I can configure my DLink camera to FTP upload to Weather Underground OK. Seems to works every time.


    In trying to troubleshoot that issue, I also tried to FTP images from a Linux board using NCFTP and LFTP to GaDaddy. Same thing - works OK once in awhile, but times out most of the time. 


    I also tried to FTP on my Windows 10 machine from the command prompt. I can sign in OK, but when I try to do a 'Put file.txt', it responds with:

    '200 PORT command successful'

    but eventually says
    '425 Could not open data connection to port 54317: Connection timed out'


    I have tried turning off my firewall, but that doesn't help. It appears to be an issue with just GoDaddy FTP, but then again FileZilla works just fine with GoDaddy. BTW, their tech support couldn't find any problems with my account.


    Any and all ideas would be most appreciated!


    1 REPLY 1
    Community Team
    Community Team

    Are you trying to make these connections into an actual VPS or Dedicated Server, or is this a shared hosting environment?  If you're using a VPS I'd recommend testing access to the server via the various devices from another network to see if you're able to maintain a stable connection or if you can duplicate the problem.  

    If you receive the same errors across multiple connections, I'd suggest running an trace route from both networks and sharing the results with the GoDaddy support team for review.