• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Resolver I

    Hostname changes back after reboot, how to stop it?

    WHM >> Networking Setup >> Change Hostname

     

    I thought I was doing a good thing after making server configuration changes to go ahead and "Graceful Server Reboot" from WHM. I happened to click through the Change Hostname page and noticed the original setup ip-123-12-12-123.ip.secureserver.net text in the field. I changed that back to what I want it to be "host.domainname.tld" for example. 

     

    Anyone experience this on a dedicated server or virtual server? I'm on a dedicated server less than a year old. 

     

    Do I have to go digging for other changes to default after a reboot? 

    .....................................................................................
    Domainer, Web Developer, JohnNapoletano.com
    1 ACCEPTED SOLUTION

    The account with problems for me was a dedicated server but maybe the issue is the same. From what I remember, the issue had to do with the initial setup of the hosting account. 

     

    My Account > My Servers > [server] > "Username"

     

    The combination of Username and Password was creating a conflict. So each time the server rebooted it reverted back to default for hostname field. At least two GoDaddy reps failed to ID the issue (it happens), but the third one I called around the time of post creation ID'd the issue right away. There was an error being thrown in a log somewhere.

     

    The rep changed that "Username" if I recall correctly. 

     

    Hope this helps!

    .....................................................................................
    Domainer, Web Developer, JohnNapoletano.com

    View solution in original post

    6 REPLIES 6
    Community Manager

    Hi @JohnN. I'm not familiar with this, but I found this cPanel help article that may help. 

     

    https://forums.cpanel.net/threads/hostname-changing-back-after-reboot.156521/

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    Thanks JesseW.

     

    I did see that before. The way I read it says to call Godaddy and ask them to hardcode it?

     

    Was hoping someone here on the GD forum went through this already to confirm.

    .....................................................................................
    Domainer, Web Developer, JohnNapoletano.com

    I had been having this problem for years.

    Ive now been migrated on to a new VPS with godaddy and it still happens.

     

    Really annoying because all account email goes mental everytime because it cant resolve the ssl certificate either and the a record also gets reset.

     

    Currently in contact with godaddy's support to see if i can fix this once and for all.

    Ill post up if it can be done.

    The account with problems for me was a dedicated server but maybe the issue is the same. From what I remember, the issue had to do with the initial setup of the hosting account. 

     

    My Account > My Servers > [server] > "Username"

     

    The combination of Username and Password was creating a conflict. So each time the server rebooted it reverted back to default for hostname field. At least two GoDaddy reps failed to ID the issue (it happens), but the third one I called around the time of post creation ID'd the issue right away. There was an error being thrown in a log somewhere.

     

    The rep changed that "Username" if I recall correctly. 

     

    Hope this helps!

    .....................................................................................
    Domainer, Web Developer, JohnNapoletano.com

    View solution in original post

    I was viewing this.  I figured out the problem, but the way to find the setting is not clear.

     

    To get to the hostname setting one your virtual machine go to My Account / My Servers / <yourservername>  once you get to that page, you must go to the settings button.  This will allow you to change the hostname. 

    I should add to this - the reason why this didnt work for me it turns out is that godaddy wont allow a hostname with more than 2 periods(.) in and mine has a co.uk extension. 

    Naturally when i bought the server, sales and support were more than happy to tell me srv.X.co.uk was perfectly good hostname, but what the hell do they know, its just their job